Oil change, and PO128 720 600 500 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-20-2010, 10:22 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Oil change, and PO128 720 600 500

After getting my oil changed yesterday at Jiffylube, a check engine light came on about a mile later. They did not have the right tool to find the error codes.

Went to PepBoys, who pulled the following codes:
P0128 Coolant Thermostat Coolant Temp Below Thermostat Regulating Temperature
P0500 Vehicle Speed Sensor Malfunction
P0600 Serial Communication Link Malfunction
P0720 Output Speed Sensor Circuit Malfunction

The prior day, I had hit a rock which bounced off the bottom of the car. No error codes then, looked closely at the bottom and only found a scrape.

Do these codes sound like they all come from the same source? Perhaps transmission fluid on the connectors when they were doing the oil change?

2005 C230 3 door, Los Angeles, 80k miles, straight factory, no mods. No other recent work or problems.

Thanks for the help.
maliburenter is offline  
Sponsored Links
post #2 of 3 (permalink) Old 12-20-2010, 08:51 PM
BenzWorld Member
nenad16's Avatar
Date registered: Aug 2005
Posts: 163
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
those codes are too generic, you will have to get the car scanned with Star Diagnostics(SDS) for OEM code descriptions.

I'm not a bad christian, I'm a good atheist.
nenad16 is offline  
post #3 of 3 (permalink) Old 12-21-2010, 10:26 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,532
Mentioned: 9 Post(s)
Quoted: 1070 Post(s)
You are not going to be popular with JiffyLube.
Are you sure they didn't drain your transmission?
I would suspect a harness plug got loosen up somewhere. Too many different sensors failed at the same time to make it sensor failure.
Kajtek1 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    SL 500 M119 oil change. RedLiner R129 SL-Class 60 05-03-2011 10:54 AM
    OIL Change On 2002 SL 500 ?????? harley03joe R129 SL-Class 33 09-18-2010 01:53 AM
    600 SEL oil filter change Bourhim W140 S-Class 2 03-26-2010 11:57 PM
    ML 500 Oil Change Help Needed Wizz190E W163 M-Class 6 03-31-2008 09:08 AM
    $600 for an oil change and tire rotation mlfun General Mercedes-Benz 31 01-13-2008 07:12 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome