Another A140 problem!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-20-2010, 07:12 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Another A140 problem!!

Hi guys, having a nightmare with this car seriously wish I hadnt wasted my money buying it in the first place.

Smoke coming from drivers side rear vent above first aid compartment.
Its also coming from behind rear driver side light, could this be anything to do with fuel pump? like a electrical burning smell.

Thanks in advance guys
deanlad1980 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-20-2010, 09:09 PM
BenzWorld Member
 
unimoged's Avatar
 
Date registered: Dec 2008
Vehicle: 2004 S500. 2000 CLK430 Cab, 1999 C43 AMG. 1999 S500. 1999 S320. 1977 230 4 spd, 1972 280SEL 4.5
Location: Charlotte NC
Posts: 185
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
If I were you, I would disconnect the battery IMMEDIATELY and keep a fire extinguisher nearby.

Does the smoke stops when the car is off. What is described here is very vague but you need to assume a worst case scenario, thus disconnecting the battery immediately.

I doubt this has anything to do with the fuel pump since I am assuming that the car runs.
unimoged is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    W168 A140 immobilizer problem Lowfatslim W168 A-Class 3 07-03-2010 05:21 PM
    Problem with a140!! lazaross W168 A-Class 6 07-01-2008 06:18 AM
    remote key problem A140 pick2610 W168 A-Class 2 10-18-2007 01:21 PM
    A140 starting problem derek matheson W168 A-Class 1 03-21-2007 05:37 AM
    A140 automatic problem Guest (MBNZ) General Mercedes-Benz 0 04-05-2002 02:49 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome