2002 E320 4Matic - Transmission Gremlin? - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 01-06-2011, 05:39 PM
BenzWorld Member
 
ingydrummer's Avatar
 
Date registered: Jan 2010
Vehicle: 2005 E-500 4Matic Sedan Brilliant Siver
Location: Pennsylvania
Posts: 140
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
[This happened on my 03 320 4matic, and they told me it was a shift plate in the trans. It wound up costing me $1250.00 plus labor.
ingydrummer is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 06-13-2011, 10:29 PM
Lifetime Premium Member
 
Date registered: May 2011
Vehicle: 2001 Mercedes SLK320; 2002 Mercedes E320 4Matic S/W; 1990 Mercedes 420SEL
Location: Carbondale, IL
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Mine has gone into the limp mode, and when I opened the pan, and found there was actually coolant in the fluid. Took out the Valve Body, and now will be testing the Solenoids, and will have to replace the Electric Conducting Plate (Electrics Plate), and flush the transmission of all and any remaining coolant. Refill, and test. Might have to go see the Benz Dealer for programming. Anyone has any other thoughts?
navreet is offline  
post #13 of 14 (permalink) Old 06-14-2011, 02:41 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,450
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
Do you have a Valeo radiator? If so, look up the threads on the leaking Valeo problem in the archives...
keyhole is offline  
post #14 of 14 (permalink) Old 06-14-2011, 02:51 AM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Quote:
Originally Posted by navreet View Post
Mine has gone into the limp mode, and when I opened the pan, and found there was actually coolant in the fluid. Took out the Valve Body, and now will be testing the Solenoids, and will have to replace the Electric Conducting Plate (Electrics Plate), and flush the transmission of all and any remaining coolant. Refill, and test. Might have to go see the Benz Dealer for programming. Anyone has any other thoughts?
Quote:
Originally Posted by keyhole View Post
Do you have a Valeo radiator? If so, look up the threads on the leaking Valeo problem in the archives...
Whatever radiator he has, he needs a new one.

Navreet, flush the cooling lines before you reconnect them and actually leave the supply line loose from the radiator. When you start it back up let it flush out 1L and refill 1L at a time until you've done that about 9 times to be sure you get it out of the torque converter.

I'd probably do another fluid change in a few thousand miles.

Good luck.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2001 E430 4matic or 2002 E320 4matic alexnatt W210 E-Class 16 08-02-2010 11:54 PM
    New to me 2002 E320 4matic AWD Sibarks General Mercedes-Benz 2 12-05-2009 07:06 PM
    OBDII for my E320 2002 4matic wagon, where should I get one? Maflaya W210 E-Class 2 08-15-2008 06:14 PM
    Is this nice or what!? 2002 E320 4matic on ebay. ozcan W210 E-Class 12 07-24-2008 09:57 PM
    RIMS FOR 2002 E320 4MATIC Guest (MBNZ) The Discount Tire Direct Tire, Wheel, Brake & Suspension 1 11-16-2001 06:38 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome