Motorproblems 350 V6 petrol engine 272 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-16-2010, 10:48 AM Thread Starter
BenzWorld Member
Date registered: Jun 2005
Vehicle: 07 R 280 CDI
Posts: 217
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Motorproblems 350 V6 petrol engine 272

Due to weak materials in balance shaft for engine numbers up to Serial No. 2729..30 468993 , Mercedes Benz has issued the enclosed service bulletin S-B 03.30/08 j as of june 17 2009. Based on this the balance shaft will have to be replaced. If you haven't heard of this before, please notice this and do an enginge diagnosis for this asap. Symptom is yellow check engine light coming and going. Anyone out there who has experience on this please give me a pm, also describing how your local dealer handles this, as this should be a warranty issue.

Best from Kjetil Halvorsen Norway

2007 R 280 CDI
2009 BMW K1300S

x -CLS 350
x -CL 500
x -R 320 CDI
x -500 SL
SLNorway is offline  
Sponsored Links
post #2 of 9 (permalink) Old 01-17-2011, 07:57 AM
BenzWorld Member
V1VRV2's Avatar
Date registered: Jun 2008
Vehicle: 2000 E320 Original Owner 2007 CLK550 Cabriolet
Location: Fayette County GA
Posts: 179
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
My car only has 18,000 miles. The service advisor said there was nothing he could do until the check engine light came on. I was hoping he would replace the gear. Looks like I'll be getting the extended warranty.
V1VRV2 is offline  
post #3 of 9 (permalink) Old 01-17-2011, 12:19 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
IIRC this also affects the 273 motor.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #4 of 9 (permalink) Old 01-17-2011, 01:30 PM
BenzWorld Member
Date registered: Dec 2005
Vehicle: 2005 C350, 2002 ML270CDI, 1969 230S, previously 2002 A160, 1985 380SEC ivory, 1983 380SEC grey
Location: Adelaide South Australia
Posts: 82
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi SLNorway,
Yes I have heard of this fault. I thought it was wear of the idler sprocket on the cam shaft chain which changed the timing of the cam shafts, and made the engine computer very unhappy. The hardening of the teeth of the idler sprocket was not done correctly, leading to premature wear.
As a precaution I had a DAS reading sone on my C350 engine at 95,000km before the extended warranty ran out :-) at 100,000kms
The camshaft position angles for both intake and exhaust were quite close th the middle of the permitted range, so my Service Advisor said there was nothing to worry about [as he would :-( .....].
If you like I could scan the page and try an attach it for your information.

Cheers from Down Under
Audiophile_AU is offline  
post #5 of 9 (permalink) Old 01-18-2011, 11:51 AM
BenzWorld Elite
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
These problems were fixed with running factory production changes, so the bulletins contain a range of applicable engine serial numbers. It's the early production M272 and M273.

Kent Christensen
'07 GL320CDI
lkchris is offline  
post #6 of 9 (permalink) Old 03-20-2011, 08:55 PM
BenzWorld Newbie
Date registered: Mar 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I just got my CPO 08 E350 with 33K mile in Feb/2011, within a week the CEL turned on then went away the next day, It happened a couple more times just like that but the car/engine ran smoothly . I called the dealer a took the car in for check. They diagnosed with code P1200 and P1208 and replaced the magnets on the left bank intake/exhaust cams, and declared problem fixed, I took the car home and the very next day the CEL turned on again for two day and turned off by itself again. I took the car back to the dealer and later they informed me that the procket and balance shaft needed to be replaced. It's been more than 2 weeks and the dealer has not finished yet!
My engine serial# is 2729..30 78xxxx which is > 2729..30 468993, is It possible that my engine has the same problem as described in S-B-03.30/08i?
thangng is offline  
post #7 of 9 (permalink) Old 03-24-2011, 01:50 PM
BenzWorld Junior Member
Date registered: Jan 2009
Vehicle: CLK 350, C240 4Matic, M3 Conv, Boxster S, S2000, Range Rover
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Check Engine Light P0016 Code. Worn Balance Shaft Cam Gear.

My SRS light came on so I took it to the dealership. Apparently it was a wire under the passenger seat. So they fixed that for about $500 and within 2 days of getting the car back the Check Engine light came on.
This time it is the dreaded P0016 code. They are saying its worn Balance Shaft Cam Gearing. My Car has around 77k miles. Has anyone fixed this out of warranty? Any insight will be highly appreciated.
faheemf1 is offline  
post #8 of 9 (permalink) Old 07-29-2011, 03:26 AM
BenzWorld Newbie
Date registered: Jul 2011
Vehicle: E350 Avantgarde Sports pack 2005 model
Location: Brisbane, Qld Australia
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
OUr car has done 119,000km (we purchased it new in Dec 2005) and the engine light has just recently come on - intermittently at first, but now it is on all the time.
We have just had a diagnosis done at MB Brisbane and they say that both the exhaust and intake camshafts are retarded which was caused by a worn balance shaft.
Cost for repair of this through MB Brisbane $7940.00.
As this seems to be a more common problem, we would like to find out more.....
Where can we see this "service bulletin S-B 03.30/08 j as of june 17 2009" that you mentioned?

Last edited by CorandIngeborg; 07-29-2011 at 03:52 AM. Reason: incorrect spelling
CorandIngeborg is offline  
post #9 of 9 (permalink) Old 01-14-2013, 05:15 AM
BenzWorld Junior Member
Date registered: Nov 2009
Posts: 30
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
P0016 and P0017 codes 06 ML350

Hi I just read your thread on the codes I have something of the same thing

I have a 2006 ML 350 with a check engine light displaying code P0016 and P0017. It doesnt down on and off its consitantly on. My question is I just had that balance shaft problem that cost about 5k done by the dealer 1 year ago and now this

I'm confused because on some post they claim that this code along with P0016 is a simple sensor replacement.

I spoke to the dealer they want to charge me for looking at the vehicle 180.00 then if it has something to do with the balance shaft work they did they MIGHT cover it

Any suggestions about fixing the P0016 and P0017 code problem

Should I just swap out the sensors and solenoids in the front of the engine or just swap out the sensors.:crybaby2 :

Last edited by donkeydawn11; 01-14-2013 at 05:26 AM. Reason: additional information
donkeydawn11 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2006+ 272 V6 Engine Parts (cylinder heads and more) silver8723 For Sale/Wanted/Trade/Giveaway 0 11-18-2010 06:05 PM
    113, 112, 272 engine parts ML550 engine partout justinmc For Sale/Wanted/Trade/Giveaway 0 10-15-2010 10:22 AM
    M 272 3.0L Engine in W 204 C-Class johf W204 C-Class 13 07-03-2009 12:16 PM
    FOR SALE 2006 280 V6 ENGINE 272 ibizafun For Sale/Wanted/Trade/Giveaway 1 05-08-2009 02:49 PM
    Can you use 229.51 oil in V6 272 engine mitaka W164 M-Class 6 05-05-2009 01:17 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome