300SE Overheating issue? HELP!! - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 12-19-2010, 11:11 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2010
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks much for help! Problem likely was mostly due to too much sludge built up in system from the oil mixing with coolent engine design flaw and not having done a good flush in quite a while. And fan clutch is weak so think problem was probably a number of things all adding up to problem. Can't be sure if it was water pump or thermostat, replaced both, did best flush I could, all seems normal now.
drwexploring is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 12-20-2010, 06:18 AM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,282
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
I would remove and inspect the back of the fan clutch. It can break sort of in a ring shape. If it does, the fan will wobble and come loose. I found this out the hard way last summer. "Luckily" the fan hit the radiator instead of damaging anything else. Here is a thread about it:

http://www.benzworld.org/forums/w126...-pump-but.html

Mike
Michael Pillay is online now  
post #13 of 13 (permalink) Old 12-20-2010, 08:54 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2010
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
hey Thank you for the heads-up!!! APPRECIATE IT!!! Will have a close look at that.

HAPPY HOLIDAYS!
drwexploring is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    All things considered (300se overheating issue) Htown W126 S,SE,SEC,SEL,SD,SDL Class 32 06-08-2014 03:24 PM
    Overheating Issue yoffer W210 E-Class 4 06-24-2010 04:34 PM
    300SE Overheating Problemo hvc78 W140 S-Class 6 03-04-2010 05:46 AM
    overheating issue. jbrunner27 W126 S,SE,SEC,SEL,SD,SDL Class 2 09-16-2007 03:00 AM
    Overheating Issue satyr W201 190-Class 6 05-18-2005 02:03 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome