ML320 doors unlock continually - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-03-2010, 03:46 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: 2001 S600 AMG, 67 Corvette, 71 Hemi Cuda
Location: San Francisco Bay Area
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML320 doors unlock continually

I have a 2001 ML320 and a couple weeks ago the FOB quit working so I changed the batteries and still no good.

Went to the dealer, $200.00 for the key and $200.00 to program it.

Figured I would wait and just lock the car manually. LOL

A few minutes later the car unlocks itself and does it again every 5-10 minutes.

All the actuators are working and so the battery won't go dead and the car remains locked I've been disconnecting the battery. I pulled all the relays and fuses too.

Is there a way to disable the auto lock feature?

Does anybody know where the main control unit is for the door lock system ? All I can think of is maybe the unit thinks the cars is stopping and its signalling for the doors to unlock.

Thanks
427vette@sbcglobal.net is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-04-2010, 07:04 PM
BenzWorld Member
 
Date registered: Oct 2010
Vehicle: 300CE-24, W204 C220 CDI, W210 E55 AMG, W124 300TE, W163 ML270 CDI
Location: Melbourne, Australia
Posts: 399
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to Mcmerc01
Seems that its most likely the key fob, and that price seems expensive, shop around. Try independents as well. Does it unlock after 5-10 minutes with you around the car? Have you tried possibly locking it, and putting the key very much out of range and waiting to see if it unlocks again.

Could be the door lock control unit playing up, thats what I've seen happen once. Sorry If I can't help much...
Mcmerc01 is offline  
post #3 of 9 (permalink) Old 12-07-2010, 01:15 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: 2001 S600 AMG, 67 Corvette, 71 Hemi Cuda
Location: San Francisco Bay Area
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I was wondering where the door lock control is?

I tried taking the keys very far away and the car keeps unlocking. I wasn't sure if its the fob sending the signal or the key but I took the batteries out of the fob.

Locked it using the key on both door and still it unlocks. Locked it using the power door lock switch and still unlocks.

I took the keys to work with me and had them lock it. It unlocked itself again.

Too crazy.

So now I lock it and disconnect the battery.

Thanks, any help is appreciated.
427vette@sbcglobal.net is offline  
post #4 of 9 (permalink) Old 12-07-2010, 02:39 AM
BenzWorld Member
 
Date registered: Oct 2010
Vehicle: 300CE-24, W204 C220 CDI, W210 E55 AMG, W124 300TE, W163 ML270 CDI
Location: Melbourne, Australia
Posts: 399
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to Mcmerc01
Take it to an indie mercedes independent, that way it won't burst the bank fund wise, have them check the electronics and the door lock control. Its the best thing to do, and possibly the only thing.
Mcmerc01 is offline  
post #5 of 9 (permalink) Old 12-09-2010, 12:52 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: 2001 S600 AMG, 67 Corvette, 71 Hemi Cuda
Location: San Francisco Bay Area
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, looks like the best route. I think its the door control. All the latches are working and it just keeps popping them to open when in park. Its fine when is moving.
427vette@sbcglobal.net is offline  
post #6 of 9 (permalink) Old 01-17-2011, 05:39 PM
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
There are a couple of other threads on this site that may provide answers to your question. One of them is this one: http://www.benzworld.org/forums/w163...-lock-not.html

Also here are some good instructions for removing the console in order to get to the power block for the windos, door locks, side view mirrors etc: Simple Web Page
arginkc is offline  
post #7 of 9 (permalink) Old 01-17-2011, 06:00 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: 2001 S600 AMG, 67 Corvette, 71 Hemi Cuda
Location: San Francisco Bay Area
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for the input.

It got to be that I had to remove fuse 42 just to keep the ML320 locked although it still would try to unlock and the interior lights would come on through out the day and night no matter what.

I moved relays all around and fuses. All made no difference.

Then I bought a service manual and started looking through it and most things point to the All Activities Module or AAM. I checked pricing on the AAM but it still had to be programmed by MB.

I broke down and paid a $170.00 fee to the local dealer to diagnose it. They came up with the AAM too. I spoke with the tech and he said that the AAM was not reading anything on the car. It apparently died. So a new AAM is ordered and it will be installed this week. $1200.00 $400.00 for the AAM, the diagnostic time, install and programming.

The AAM on Jan 01 to Feb 01 ML320 vehicles were bad and were replaced. This ML being built in March had the better AAM I guess!
427vette@sbcglobal.net is offline  
post #8 of 9 (permalink) Old 01-18-2011, 07:08 AM
BenzWorld Elite
 
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T and others
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Go back to the dealer and demand they fix it, $200 for the remote is fair, but the $200 labor is excessive. I assume this is not a Smart Key. The shop computer can read codes, do you have more than one remote? My 99 ML had locking issues, they experimented by replacing the locks, and then burned up the AAM it finally turned out to be a bad actuator in the tailgate. Indie mechanix have very little skill and tools to diagnose.
Peter Guenther is offline  
post #9 of 9 (permalink) Old 01-19-2011, 06:25 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,465
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
It could be the AAM (N10) - but probably is not.

From WIS for your model:

"When the driver's door is opened, (from the inside) the fuel filler cap is unlocked if the driver's door has been locked previously.

The All-activity-module AAM (N10) recognises that the driver's door is unlocked by the right front door microswitch (M14/5s1). It then unlocks the driver's door group and the fuel filler cap electrically."

So your spurious door unlocking could be caused by a faulty microswitch in the door.
keyhole is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    How to unlock the doors? andrew_falky W210 E-Class 17 12-07-2009 12:53 PM
    doors don't unlock logan.suhrer W123 E,CE,D,CD,TD,TE Class 1 07-18-2009 11:26 PM
    Doors unlock themselves RSK_W123_230E W123 E,CE,D,CD,TD,TE Class 4 11-10-2008 07:22 PM
    Cannot unlock doors HELP !!... shogun1480 General Mercedes-Benz 7 04-10-2008 08:54 PM
    Doors Won't Unlock MARY E W203 C-Class 8 04-02-2007 09:40 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome