Hello - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 11-29-2010, 09:40 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2010
Vehicle: 1986 190e 2.3 8v
Location: South FL
Posts: 154
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Talking Hello

Hello my name is AX, and i recently got my first MB not long ago, it is a '86 190E 2.3...
I really like the car, and i would like to bring it back to glory. Hoipefully with your help. I'm pretty good around a car, but this one is a lil different from the chevys that i've been stuck on...
anywho......... glad to be here and let the games begin!!!!!


Last edited by ax456; 11-30-2010 at 12:10 AM.
ax456 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 11-29-2010, 10:24 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld

W201 190 Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 12 (permalink) Old 11-29-2010, 11:35 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2010
Vehicle: 1986 190e 2.3 8v
Location: South FL
Posts: 154
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
TY Eric, As i scour through the posts trying to find fixes to my issues......i believe i found one.....motor mounts....my car all the sudden has been shaking/shuddering something aweful on acceleration. i'm now recalling a bang coming from under my center console area..........i was like WTF was that!...(motor mount pieces flying?)....that was prob when the bad vibes/shuddering got real bad. i will check it in the AM as it is pretty late now.
ax456 is offline  
post #4 of 12 (permalink) Old 11-29-2010, 11:40 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
More likely the propshaft rubber couplings.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #5 of 12 (permalink) Old 11-29-2010, 11:53 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2010
Vehicle: 1986 190e 2.3 8v
Location: South FL
Posts: 154
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
where do i find these? i mean on the car? are they in the driveline?
ax456 is offline  
post #6 of 12 (permalink) Old 11-29-2010, 11:56 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Flexi disc is at the end of the transmission and the front of the prop;
Flexi disc kit A108 410 01 15

Or the center propshaft rubber mounting in the center of the two piece prop shaft A111 413 00 12

You will understand better when you can get under the car.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #7 of 12 (permalink) Old 11-30-2010, 12:06 AM Thread Starter
BenzWorld Member
 
Date registered: Nov 2010
Vehicle: 1986 190e 2.3 8v
Location: South FL
Posts: 154
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
kewl thanx, i'm flippin through my haynes manual and i gotta say its the worst haynes manual i ever had!!! i have an idea whats up....makes sense and i will definately check it in the AM.

okay , if i may........since i believe i'm talkin to the right guy.......my car has a "chirping" ...to me it makes my car sound like a VW bug. is this normal? or how can i fix that?

This 190 is my first benz and i got it for next to nothing, to save $ on gas. Turns out this car is stealing my heart. It is a very fun car and i really appreciate the way it drives even being 24 yrs old and tired.
ax456 is offline  
post #8 of 12 (permalink) Old 11-30-2010, 12:21 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
The chirping sound is most likely a belt or one of the pullies but I am guessing as we do not have any 190 in this country so I must fall back on technical experience for which I have a lot lol.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #9 of 12 (permalink) Old 11-30-2010, 12:28 AM Thread Starter
BenzWorld Member
 
Date registered: Nov 2010
Vehicle: 1986 190e 2.3 8v
Location: South FL
Posts: 154
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
just read another post.....said chirping waiting at the light----->YES, then put it in neutral it stops------;--->YES....prob motor mounts.
but the vibrtion really to me sounds/feels like these flex discs.

JOY......... MY RUBBER IS MUSHY!

okay so now i ask you this, do you know where can i find polyurethane to replace this rubber?
ax456 is offline  
post #10 of 12 (permalink) Old 11-30-2010, 12:37 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Sorry I would not know where to buy as I am in China and we only use OEM parts.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome