1998 420 S Poor Radio Reception - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-11-2010, 10:17 AM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1998 420 S Poor Radio Reception

The antenna fell off the vehicle several years ago. $700 later, a new antenna was installed but with very poor radio reception. Yesterday the damn antenna fell off again, however was still hanging by the plastic gear. I was able to feed the plastic gear back through the motor and have it connected and operating again, but now the reception is even worse. I tried bypassing the combiner box and connected the radio co-axil directly into the neck of the antenna housing, but this did not help. I noticed that the "rubber wedge nut" that mounts to the outside of the vehicle has maybe a 2-3" bent stiff wire that protrudes out of the rubber stop and into the vehicle. I don't know what this does and/or if it is broken. Everything is stock, no aftermarket radio/antenna's are used. Any suggestions that would help increase the radio reception would be appreciated.

Last edited by valtski; 11-11-2010 at 10:20 AM.
valtski is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-11-2010, 10:40 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
MB calls your car a W140 and there is a dedicated forum for those. Just scroll down from this general forum until you see the sedans section. There are bound to be other like owners who have had a similar problem. Good luck and welcome.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 3 (permalink) Old 11-11-2010, 12:54 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you

I will check the sedan section
valtski is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Poor radio reception Thomasbhughes C208/A208 CLK-Class 1 07-05-2008 11:39 AM
E-320 poor radio reception jnstro W210 E-Class 6 04-30-2008 06:30 PM
Poor radio reception? Read this... hishamz W210 E-Class 1 12-08-2005 12:14 PM
Help with Poor AM Radio Reception. elladdin W163 M-Class 10 11-08-2004 08:32 PM
Help with Poor AM Radio Reception. elladdin W163 M-Class 0 11-04-2004 06:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome