1991 420sel with a high idle and becker stereo issue - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 11-09-2010, 09:40 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2010
Vehicle: 1991 420SEL
Location: Scappoose,Oregon
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1991 420sel with a high idle and becker stereo issue

Hi, I just picked up a 1991 420SEL. I need to ask a couple of questions. This car sat for four years. The previous owner did a pro tune-up before parking the car and believed everything was in good order. When I bought the car the battery was dead. After putting in a new battery the car started and drives. Problem 1. The radio/ CD does not come on... are there start-up codes for these becker stereos and how do I find them? Problem 2. The car idles at 2K in park but runs fine under a load in drive? Has anybody had these problems? And can you help with some advice. Thanks in advance.

Last edited by lendicott; 11-09-2010 at 09:42 AM. Reason: mispelling
lendicott is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 11-10-2010, 05:40 PM
BenzWorld Senior Member
 
waybomb's Avatar
 
Date registered: Apr 2005
Vehicle: 2005 S55; 2003 ML350; 2002 C240; 1997 C280 Sport; 1991 300SL; 1986 190e 2.3 16V (2); 1968 W30 442
Location: South of the North Pole
Posts: 528
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Go to the 126 section and do a search for "high idle". You'll have pages and pages to read.

Thanks!
Fred
2005 S55
2003 ML350
2002 C240
1997 C280 Sport
1991 300SL
1986 190e 2.3 16V (2)
1968 W30 442
1988 46' Cougar US1 with Triple blown 572s
http://s4.photobucket.com/albums/y145/waybomb/
Warming the Globe, 24 Cylinders at a Time
Point me to a 126 wagon in the States PLEASE!
waybomb is offline  
post #3 of 14 (permalink) Old 11-10-2010, 07:10 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2010
Vehicle: 1991 420SEL
Location: Scappoose,Oregon
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
high idle

Thanks, I will check it out. I appreciate the help.
lendicott is offline  
post #4 of 14 (permalink) Old 11-10-2010, 11:41 PM
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
CHECK YOUR AIR FILTER AND VERIFY NO TROUBLE CODES HAVE POOPED UP FIRST. IF SO, READ THEM AND CORRECT FOR THEM.
Holmes John is offline  
post #5 of 14 (permalink) Old 11-11-2010, 07:58 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2010
Vehicle: 1991 420SEL
Location: Scappoose,Oregon
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
high idle

Thanks, I will check that. I seem to heading toward cleaning or replacing the idle control valve. This is a project car for my younger son and when the problems are smoothed out it should be a safe and very cool cruiser. thanks again for the help.
lendicott is offline  
post #6 of 14 (permalink) Old 11-11-2010, 09:40 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Re the Becker radio: If all you needed was the radio code it would turn on and ask you for it. If it worked any dealer should be able to provide you with yours. Several members have sent theirs to Becker for repair and have been satisfied. Also I think there might be a fuse on the back of it. As advised, check the W126 section for that too.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #7 of 14 (permalink) Old 11-11-2010, 10:07 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2010
Vehicle: 1991 420SEL
Location: Scappoose,Oregon
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
dead radio

Thanks for the tip, I was thinking fuse... and had looked under the hood. Everything there checked out fine. I will check the unit itself for a fuse now. Thanks again for the advice.
lendicott is offline  
post #8 of 14 (permalink) Old 11-11-2010, 10:16 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
You're welcome. I know for a fact some of these radios have fuses on the back, I'm just not familiar with the 420SEL series.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #9 of 14 (permalink) Old 11-11-2010, 10:28 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2010
Vehicle: 1991 420SEL
Location: Scappoose,Oregon
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
getting there

Taking the radio out and getting to the fuse will be the challenge. This will be my Veterans Day chore. Put a fire in the shop and try to get some music in this old car. Happy Veterans day all.
lendicott is offline  
post #10 of 14 (permalink) Old 11-11-2010, 10:58 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Dealers sell MB radio removal tools for not much money but some members have made their own. Probably available online too. They are just narrow wire hook-type things that you slide in the sides of the radio, rotate so they grab, then pull the unit out.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Hesitation/Stumble/High Idle W126 420SEL BenzFreak$$ W126 S,SE,SEC,SEL,SD,SDL Class 29 01-07-2013 03:38 PM
    1989 420SEL High Idle and easily overheat irvineharley General Mercedes-Benz 1 11-27-2009 11:20 AM
    87 420sel High idle and bad hesitation/stumble off idle. Please help! marzban123 W126 S,SE,SEC,SEL,SD,SDL Class 18 07-10-2009 01:42 AM
    420sel with very high idle upon start. 1FastGT W126 S,SE,SEC,SEL,SD,SDL Class 7 03-10-2009 12:30 AM
    1991 420SEL = stereo question MECTHET W126 S,SE,SEC,SEL,SD,SDL Class 4 01-22-2003 05:27 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome