96 odometer mileage clock constant on - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-29-2010, 07:16 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
96 odometer mileage clock constant on

Hello:

I have a 1996 e320 with a l6 3.2 liter engine 150,000ish miles. The odometer , mileage, temperature and clock on the cluster stay constantly lit even after several minutes with the key removed from the ignition. The battery was replaced recently but the customer does not remember this being lit constantly. Any suggestion as to a cluster failure or another issue would be great as I am not very fluent with euro’s.

Thanks.
jefb is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-29-2010, 08:47 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
I'm not fluent with these either but I can suggest you scroll down to the W210 forum found in the sedans section. There are a few real "whiz kids" who can probably help you. Just a WAG: the car evidently thinks the key is still in the ignition so I would suspect something with the ignition system like in the tumbler mechanism. Good luck.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Odometer and trip mileage not working 300seTexas W126 S,SE,SEC,SEL,SD,SDL Class 11 07-19-2010 02:34 PM
    1/2 Dim Temp/Odometer/Clock Display EasyE430 W210 E-Class 4 04-30-2010 12:27 AM
    U1300L Mileage (odometer reading) Oldmog Unimog 4 08-01-2009 11:45 PM
    How to adjust mileage on odometer??? jtoma878 W123 E,CE,D,CD,TD,TE Class 3 01-07-2007 10:00 AM
    Initial mileage: What was your odometer reading? reallife R171 SLK-Class 44 09-11-2006 03:46 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome