W124 low idle and stalling - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-28-2010, 12:57 AM Thread Starter
BenzWorld Junior Member
 
londonxxi's Avatar
 
Date registered: Aug 2010
Vehicle: 1994 E420, 221,xxx
Location: California
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post W124 low idle and stalling

Hello all,

So this past Sunday I was on the freeway driving to work, and one of my radiator hoses came disconnected, draining my coolant, and causing the car to overheat. I work for a Mercedes dealership, so I had the car brought in, and one of the technicians replaced the hose. While he was at it he replaced the coolant level sensor which had been out for a while.

I picked up the car today, and noticed immediately that it was idling very low (about 400 rpm), and when I would come to a stop it would sometimes die.
Also the coolant light is back on, but the coolant level is just fine...

I have the car back at the dealership and they should be checking it out tomorrow. I just wanted to see what anyone on here had to say about this. I don't really know what could be causing the low idle other than the idle sensor... I don't even know if these two incidents are at all connected...

Any feedback would be greatly appreciated!

Last edited by londonxxi; 10-28-2010 at 01:02 AM.
londonxxi is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Help, Low-RPM hesitation and stalling @ idle??? b5-turbonium W210 E-Class 4 12-30-2012 12:48 AM
    Low idle, rough idle, stalling, hot and cold start solved: E320/300 rvenerac W124 E,CE,D,TD Class 10 03-23-2010 12:28 AM
    96 E320 Cold Start issues. Stalling under throttle, misfiring, low idle, etc... RichPugh W210 E-Class 4 03-17-2009 11:56 AM
    W124 E300D Engine Idle Speed Low p_aplin W124 E,CE,D,TD Class 0 06-06-2008 07:04 AM
    low idle and stalling Guest (MBNZ) W124 E,CE,D,TD Class 3 11-18-2001 11:11 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome