1991 300 SE W126 Radiator light problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-27-2010, 07:57 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1991 300 SE W126 Radiator light problems

Hi all... my old mercs radiator light keeps coming on intermitantly... its curios as some times it uses water and sometmes it doesnt, when i topped up with water the light used to go out... now it stay on permantley... any suggestions?
ps the oil is clean so not going into engine... sometimes shows we patch on sump cover

regards

steve
rendersystems is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-27-2010, 03:48 PM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,462
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
You are referring to the 'coolant level indicator'. Did you consider that the sender might be faulty..?
keyhole is offline  
post #3 of 4 (permalink) Old 10-28-2010, 10:51 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
i dont know what a sender is im a thicko plasterer
rendersystems is offline  
post #4 of 4 (permalink) Old 10-28-2010, 05:02 PM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,462
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
LOL.. Well, it's the coolant level switch. Sometimes called a sensor or sender.

Should be on/near the coolant expansion tank.
keyhole is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1991 300 SL multi Problems uhenry1 R129 SL-Class 3 07-22-2007 05:39 PM
    1991 300 CE Acceleration problems Swimmer_X W124 E,CE,D,TD Class 6 07-04-2007 02:43 PM
    1991 300 SEL problems judybe General Mercedes-Benz 5 02-09-2006 02:59 PM
    1991 300SE(w126) Radio Problems Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 4 07-16-2001 05:21 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome