Hello - with Bas ESP problems :( - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-26-2010, 07:01 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello - with Bas ESP problems :(

Hi all new to this site I bought my A Class a few weeks ago with 50K on the clock my first Mercedes. Been experiencing problems with my A160 - BAS ESP light switches on and the car completely loses all power, no response from gearbox, press down on accelerator, no response. Car doesn’t even idle just completely shuts down. It comes magically back to life when I restart the car. Happened in traffic on the motorway - shifted from 5th to 3rd to 1st, car powered down and broke slightly to a stop. Lifted up on the accelerator and the BAS light came on, could hear the car struggling and the car shut down.
I really enjoy driving my A-class but after reading the vast array of problems that this could be I’m at a complete loss to where I start in trying to rectify this - should I take it to MB to solve, or can anyone help me diagnose a solution to this recurring problem that’s driving me crazy. HELP!!!!!

Last edited by Bhav101; 10-26-2010 at 07:05 AM.
Bhav101 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-26-2010, 09:03 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Look for the A-Class forum and post this there; I think it's in the sedans section. Good luck and welcome to the forum!

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    BAS ESP light problems (Plz help) rami2r W210 E50 AMG, E55 AMG 1 09-03-2007 08:43 PM
    BAS/ESP problems 2000 230K chris_LA W202 C-Class 6 02-28-2007 10:12 AM
    Aircondition and ESP/BAS problems adrbsl W203 C-Class 7 10-17-2006 11:59 AM
    BAS/ESP problems 2000 C230K chris_LA W203 C-Class 0 03-03-2004 04:00 PM
    Problems with BAS/ESP SteveL W163 M-Class 3 05-15-2001 01:59 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome