Ignition Key Problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-20-2010, 12:41 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2009
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ignition Key Problems

For starters, my apologies if there's an answer I couldn't find through a Google search. If someone has it, please post the link (or the keyword). That would be enough, thank you.

Otherwise, here's the problem: every morning when I try to start my 2004 500 CL, it takes me a dozen tries before the car recognizes the key.

Cleaned key and switch, nothing. Bought a new key from dealer, nothing: same problem. Changed batteries on old AND new keys. Nothing. Main battery is fuly charged.

The weirdest part is, when the vehicle has started once, it goes on and off all day without a hitch. Early next morning, the problem resurfaces.

If I lived, say, in Canada I'd think the temperature change might make a difference but in Miami we go from the 90's to as low as 72 at night.

So, should I go to a stealer & have it install a new switch or someone has a bright idea like check some connection that may loosen up at night?
Triluxor is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-20-2010, 02:14 PM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,462
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
Could you be a bit more explicit about what happens here?

When you first put the key into the Electronic Ignition Switch EIS (N73) in position 0, do you hear any noise? You should get a 'hand-shake' communication between the IR transmitter in the EIS and the IR receiver in the key, which initiates 'Drive Authorisation'. The noise is the steering lock withdrawing. If everything sounds dead, you have an EIS problem.

The EIS is also involved with the gear selector lever in P, and the stop lamp switch under the footbrake. That's why you have to have your foot on the brake and also be in Park, to enable the key to turn for starting.
keyhole is offline  
post #3 of 4 (permalink) Old 10-24-2010, 10:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2009
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the reply.

No, no noise. Nothing. Of course, I do have the gear in Park and the foot on the brake pedal. It's as if it didn't recognize the key.

Everything else works just fine. The car opens, switches headlights on, etc. but when I put the key in after sitting idle at night, it takes me anywhere from 3 to 12 tries before it recognizes the key.

What drives me nuts is that, once started and driven a few miles, it keeps recognizing the key at first insertion all day long.
Triluxor is offline  
post #4 of 4 (permalink) Old 10-24-2010, 10:17 AM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
probably have a bad EIS (ignition switch).
Streetglower is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    '86 190e Ignition key problem- the key won't turn Guest (MBNZ) W201 190-Class 7 04-13-2010 04:35 PM
    CLK430 ignition key problems doccherry C208/A208 CLK-Class 4 04-03-2010 05:10 PM
    Key won't go in to the ignition z0n3 W140 S-Class 5 04-22-2009 06:39 AM
    CL500 Card Key & Master Key alarm problems Dreamy Hikes W140 S-Class 0 02-09-2009 12:09 PM
    ignition key lock problems tablahan W163 M-Class 0 09-11-2004 06:40 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome