Mercedes virgin - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-11-2010, 08:50 AM Thread Starter
MGD
BenzWorld Senior Member
 
Date registered: Oct 2010
Vehicle: '11 Santa Fe LTD V6 AWD-Navi, '99 CLK 320 (traded for family mover), '96 200SX (SOLD) :(
Location: Hanmer, ON, Canada
Posts: 528
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Mercedes virgin

Hi everyone,

Just bought my first ever Benz, 1999 CLK 320 coupe. Was in mint condition and relatively low K's (118 000). It goes in for a full detail this weekend which should make her look real sweet as it's black and looks tired at the moment. I've ripped apart the shifter and fixed the issue with it not shifting from "D" to "4". Wasn't too bad, took me an hour. (I should have taken pics as it seems this is common). Next will be lubing the multifunction switch as it seems a little bindy and squeaky. After that I have too figure out the rough idle that it gets sometimes as it has tripped the check engine light once already. other than that runs nice when cruising .


Thanks for having me on this sight and talk to you guys later.

Marc
MGD is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-11-2010, 02:44 PM Thread Starter
MGD
BenzWorld Senior Member
 
Date registered: Oct 2010
Vehicle: '11 Santa Fe LTD V6 AWD-Navi, '99 CLK 320 (traded for family mover), '96 200SX (SOLD) :(
Location: Hanmer, ON, Canada
Posts: 528
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
After doing the whole reset ECU thing and still having rough idle, i further investigated the issue (thinking it might be the MAF sensor) and i discovered a loose (at this point unplugged) vacuum line just at the rear of the engine on the driver's side under the engine cover. Plugged it back in and voila!, no more rough idle. We'll see over the next couple of days how it goes.

It seems the rubber elbow of the hose was sitting partially on the steel hard line it plugs into causing intermittent rough idling until finally it just came off altogether making it almost chug at idle. Hope this helps others. it was pretty apparent once under the hood because you could here the distinct hiss (much more pronounced than normal). I can see how this would happen as it sits precariously close to the path of the support for the cover when putting it back into pace.

Marc
MGD is offline  
post #3 of 4 (permalink) Old 10-21-2010, 10:00 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #4 of 4 (permalink) Old 10-21-2010, 10:04 PM
BenzWorld Extremist
 
scottx's Avatar
 
Date registered: Apr 2010
Vehicle: 85 190e/8v & 89 420 SEL
Location: New Braunfels, Texas
Posts: 1,073
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to scottx
Welcome to Benzworld!

Professional Mobile Electronics Installer & Fabricator [R]
Champagne Dream - w201.024 - http://www.ChampagneDream.org/
scottx is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Not A Mercedes Virgin - Been Had Before wpterry R/C107 SL/SLC Class 5 07-10-2009 11:12 AM
    MB Virgin flpd211 General Mercedes-Benz 1 01-22-2009 04:38 PM
    virgin needs help spantyboy Unimog 5 10-16-2006 07:33 AM
    Mercedes Benz Virgin ChopperMario W211 E-Class 13 10-03-2005 03:07 AM
    'G' Virgin !!! Tony G-Class 4 09-11-2001 12:47 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome