My 'New' Classic 89' 560SEC - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-30-2010, 11:46 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2010
Vehicle: 1989 560SEC 'Artic White'
Location: PA
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to benrarick Send a message via MSN to benrarick Send a message via Yahoo to benrarick Send a message via Skype™ to benrarick
(Thread Starter)
My 'New' Classic 89' 560SEC

Hello Mercedes-Benz Community, my name is Ben and I am 16 years old. I have newly acquired my 89' 560SEC from my dad's friend... It is an 'arctic white' coupe with grey/tan interior. It had been sitting in this guy's barn for about 2 years and we got the car for a cheap $700. So far we have been doing some restoring to the car including the interior, motor mounts, fuses, seals, brakes, and touching up the paint. The work has been very tedious but my dad is a very good mechanic and he can handle almost everything very well. The only problem left is to figure out how to the fix the high idle problem... We have tried cleaning the contacts of the idle control system and the fuses related plus looking for any vacuum leaks. We still haven't found the problem yet so if you could help us out--that would be AWESOME. Parts for this car haven't been cheap so aimlessly replacing parts in the engine won't help. We are almost positive the idle control valve works. Anyways just telling you I'm new here and can't wait to be driving this beautiful classic on the road soon!!!

Thanks,
Ben
benrarick is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-02-2010, 03:11 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Hello 89' 420SEL dcaibo General Mercedes-Benz 0 05-05-2010 06:35 PM
    560SEC AMG headers turned out to be for 500euro: will they fit on US spec 560SEC? cascade W126 S,SE,SEC,SEL,SD,SDL Class 25 06-21-2008 10:39 AM
    Trannyupgrade on a 230E 89' VeroLab W124 E,CE,D,TD Class 0 11-24-2006 05:45 PM
    Rims for my 89' 560 SL AtlCarGuy General Mercedes-Benz 0 05-23-2005 07:47 PM
    Pics of my 89' 300E briby W124 E,CE,D,TD Class 5 04-28-2003 11:29 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome