2002 Merc Komp C230 Crank issues.... - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-24-2010, 12:03 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2010
Vehicle: 2002 Mercedes C230 Kompressor
Location: Tennessee
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 2002 Merc Komp C230 Crank issues....

I have a 2002 Mercedes Benz C230 Kompressor with approximately 80k miles. I went on a 6 hour to trip to the beach a couple of months ago and on the way back home we noticed the air conditioner started pushing warm air. But that isn't the largest problem. When we got home we noticed that it was taking 30 seconds to a minute or 2 to start. It would crank, but not start until a specific time had passed. Sometimes it would crank and start up but run very rough, almost reminding me of a bad fuel mixture. Also sometimes on the VDO screen it would say check battery/alternator. However, most of the time after 30 seconds to a min. of cranking it will start and run find all day/night until you turn it off, then back to the crank issues. It has been at an import repair shop for a month and they changed the crank sensor and fuel filter to no avail. Does anybody have any ideas? I was reading through the forums about the Mass Air Flow Sensor. Could that be the problem. The import auto shop states that the computer is not showing any codes. What can I do/check? Thanks for all of your help.

P.S. One more thing, the auto shop said that it could be my remote key? Could this be the problem??

Last edited by abeaglepi; 09-24-2010 at 12:05 AM. Reason: Added about remote key.
abeaglepi is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-24-2010, 04:12 AM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
the other possibility is a fuel pump that is failing.
Streetglower is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2002 C230 komp wiper problem alig8tr W203 C-Class 8 02-05-2014 08:04 AM
    2002 C230 Komp Coupe--Steering Wheel Controls Won't Work! mbryant107 Audio & Telematics Forum 3 07-31-2010 08:13 AM
    C230 komp electrical issues GTP/Kompressor_driver W203 C-Class 0 03-12-2008 03:57 PM
    2002 C230 Komp Sport For Sale "It's Gotta Go..." jomo14141 For Sale/Wanted/Trade/Giveaway 1 03-01-2007 07:52 PM
    2002 C230 Komp Sport Coupe / Charcoal Air Filter??? Mbarrera W203 C-Class 0 08-21-2006 12:17 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome