Screen not working on new C class - help! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-18-2010, 08:46 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Screen not working on new C class - help!

Hi guys, I am new to the forum and am hoping someone can help me.

Picked up my new C Class Sport 350cdi yesterday and the comand screen has stopped working!

It has worked perfectly but when I returned to the car the screen won't pop out of the dash at all. The button does nothing and it is not attempting to move at all. The radio works but as I can't see any stations its not much use.

I have checked fuse 26 which is for the comand system and it is fine.

My local dealer was no use as their technical staff have left until Monday.

Can anyone help or make any suggestions?

Many thanks
Tongie is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2004 S430 COMAND SCREEN STOPPED WORKING vovpar W220 S-Class 8 07-10-2016 07:28 AM
    Display Screen just stopped working EBenz2000 W220 S-Class 7 09-16-2010 09:54 AM
    Rear heated screen not working martmart C209/A209 CLK-Class 3 01-07-2010 08:28 AM
    Heated rear screen not working, any ideas? aquascape R171 SLK-Class 4 11-03-2006 07:02 PM
    Audio system & Display screen not working (ML320) mithra General Mercedes-Benz 0 06-02-2004 03:34 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome