C220 cdi not starting - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-14-2010, 07:09 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
C220 cdi not starting

Hi i have a 2002 c220 cdi with 72000 miles. I tryed to start my car this morning. When i turned the key all the lights come on but it did not turn over? Also the wipers where not working but every thing else was fine!

I left it over night and when i came out today (the next day) It fired up fine it is working a ok and i just dont understand it. can someone shed some light on this problem many thanks Alan
Alan Stevens is offline  
Sponsored Links
post #2 of 5 (permalink) Old 09-14-2010, 08:29 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,517
Mentioned: 9 Post(s)
Quoted: 1059 Post(s)
Judging from the description you must be in England?
Those engines were never sold in USA, where most of the members are from.
Not knowing your car, I can have general guess that your battery is getting weak. When voltage drops below certain mark, the computer will not engage the starter and on some models will disable comfort items to save the energy.
Other might be bad neutral switch on the transmission, or bad clutch switch if you have manual.
Welcome to the forum.
Kajtek1 is online now  
post #3 of 5 (permalink) Old 09-14-2010, 10:56 AM
BenzWorld Elite
Diesel Benz's Avatar
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,320
Mentioned: 3 Post(s)
Quoted: 32 Post(s)
Sounds to me that there is at least something in addition to a bad battery if the car started fine later on while the battery was not charged meanwhile.

Anyway a bad battery may prevent the drive current to the starter motor. It can be from the solenoid not having enough power to engage or the starter relay or some bad contacts at the front SAM.

Would be useful to know if there was a good "click" sound from the starter motor solenoid or a faint "click" from the starter relay or no sound at all.
Diesel Benz is offline  
post #4 of 5 (permalink) Old 11-13-2010, 09:42 AM
BenzWorld Newbie
Date registered: Nov 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi. I am from England and I too have a problem with my wiperblades not working. They did work for the wiper fluid but when you switch them on they do not work at all. Later they did not even work for this. I thought it may have been a fuse but that is fine. any suggestions? The car is a c220 cdi 2006/07
Wasif1980 is offline  
post #5 of 5 (permalink) Old 11-13-2010, 11:13 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Are you sure you checked the right fuse(s)? Sometimes they can be bad but not look like it. It's always best to check them with a multi-meter.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    C200 cdi v c220 cdi are they same engine? h9llw W203 C-Class 2 01-03-2011 01:35 PM
    1995 c220 not starting, not cranking, then OK rmaxwell2191 W202 C-Class 2 07-30-2010 07:05 PM
    C220 Automatic CDI Not starting simonbe General Mercedes-Benz 6 08-31-2009 02:47 PM
    c220 cdi help!!! stevewilson General Mercedes-Benz 1 03-21-2009 07:30 AM
    C220 CDI kevin b Benzworld Site issues forum 0 01-23-2009 04:29 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome