1991 420SEL Stumbles/Dies on take off - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-11-2010, 08:40 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2010
Vehicle: 1991 420SEL
Location: Denham Springs, Louisiana
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1991 420SEL Stumbles/Dies on take off

I have a 1991 420SEL with approx 168,000 miles. About two months ago my car would stumble if I started it up and went to give it gas to take off. It would stumble and I would take my foot off the gas and let it catch up with itself and then I could drive it and it would be fine. This only happens when the engine is warm. It never stumbles on take off if the engine is cold.

For two weeks now it stumbles every time I go to take off after the engine gets warm. It is now bad enough that it will completely die some times as I try to take off. The only way to get it to not die on take off is to take off slowly at first. However, driving in traffic I need to take off quickly sometimes.

It has two new fuel pumps, fuel filter, idle air control, and cold start valve. I cleaned the fuel pressure regulator and now have very smooth idle. The fuel distributor has been recently replaced. I haven't had a single issue with the car until this issue has me afraid to drive it around town.

Any information would be greatly appreciated!! Thanks
Colbert6920 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
300E stumbles and dies Fusion.C280 W124 E,CE,D,TD Class 7 08-01-2010 04:34 PM
92 420SEL dies leaving the light DoctorB General Mercedes-Benz 5 06-10-2010 07:25 PM
HELP PLEASE - 420SEL Suddenly Dies oz420sel W126 S,SE,SEC,SEL,SD,SDL Class 3 05-08-2009 07:12 PM
420SEL Starts well, Runs awesome, dies in grace Bear2000 W126 S,SE,SEC,SEL,SD,SDL Class 12 12-15-2008 09:21 AM
300SE warms up,stumbles, dies runover W126 S,SE,SEC,SEL,SD,SDL Class 3 01-30-2005 09:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome