2004 C230 Coupe Owner Doing Own Repair Work - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-22-2010, 02:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2010
Vehicle: 2004 C230 Coupe
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2004 C230 Coupe Owner Doing Own Repair Work

Good day. Recently got the CEL and several DTCs all at once after changing spark plugs, air filter, oil, oil filter, on the car. Based on the DTCs, replaced both O2 sensors and cleaned the MAF (by removing only the air filter, not the entire housing). Reset my OBD II (cleared it) and the CEL is off and no DTCs detected. One thing about the 2004 C230 upstream sensor - the upstream (before) sensor is 5-wire so the universal 4-wire ones won't work. I ordered the 5-wire that is made for the 2005 model year because I couldn't find a 5-wire for a 2004 C230K. The connector for 2005 was different than the existing one (2004 model). Wire on the 2005 is also much shorter. I cut the wires and used the 2004 connector on the 2005 sensor. It works!! Just wanted to share this because it did take me some research to figure this out.
mlee86 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2004 C230 parking light will not work. terry s General Mercedes-Benz 2 10-14-2009 10:26 AM
C230 Coupe - 2004 rowlands57 General Mercedes-Benz 2 03-11-2009 01:42 AM
Mod for 2004 C230 Coupe kawme SLR W203 C-Class 4 03-17-2008 09:53 AM
2004 C230 Sport Coupe : Sirius or Not? jedcred Audio & Telematics Forum 7 09-03-2005 02:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome