After Battery Died, and Charged Back Up, Is There a Reason Why My C230 Not Starting? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-17-2010, 03:43 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy After Battery Died, and Charged Back Up, Is There a Reason Why My C230 Not Starting?

Here's the story, guys:

I had an alternator warning pop up while on the way home. Luckily, I made it home and was able to bring my 2002 C230K Coupe to a gas station down the street. They diagnosed that the alternator was not sending current to the battery.

I started, and drove the car home, and once parked in the driveway, the doors locked and the alarm sounded, followed by absolutely nothing. Battery drained completely.

So I charged up the battery, but now when I turned the key, the car will not start. One click.

I'm a novice when it comes to problems like this, but I'm wondering if there is an automatic shut-off function, once the car loses all battery charge? Is there a way to reset it so I can at least start the car and drive it to a repair shop or dealer?

Seems strange, since it started fine when bringing it in for the alternator diagnosis - and driving back home.

This is also my first post, so if I've left out any key information, just let me know. Any advice/guidance would be greatly appreciated...

Thanks!
AllstonRocks is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-17-2010, 04:25 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It sounds like the alt is dead. Its not recharging the battery. My advice would be to flatbed tow it to someone who knows how to work on this car and then stick a for sale sign on it after you get it fixed.
mr.xpowerseller is offline  
post #3 of 8 (permalink) Old 08-17-2010, 06:17 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,281
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
Quote:
Originally Posted by mr.xpowerseller View Post
It sounds like the alt is dead. Its not recharging the battery. My advice would be to flatbed tow it to someone who knows how to work on this car and then stick a for sale sign on it after you get it fixed.
Sell it because he needs to have his alternator changed? Really.

Change your alternator. You can search the forum specific to your chassis. I doubt it will be difficult. If you have to have it changed by someone, no big deal. Check to see if your belt need to be changed at the same time. I would check autohausaz for a price on an alternator or see if there is an alternator/starter shop in your area that can rebuild your old one.

Mike
Michael Pillay is offline  
post #4 of 8 (permalink) Old 08-17-2010, 07:47 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,751
Mentioned: 9 Post(s)
Quoted: 1119 Post(s)
How the door locked and alarm sounded on completely dead battery?
Batteries don't like to be discharged too low and old battery can not recharge back to normal voltage after such incident. In such case the starter will not engage.
Replacing brushes or diodes on alternator is one thing, testing the battery is another.
All require some know-how but with some technical knowledge and this forum help are quite manageable.
Kajtek1 is offline  
post #5 of 8 (permalink) Old 08-17-2010, 08:20 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Michael Pillay View Post
Sell it because he needs to have his alternator changed? Really.
You missed the part about getting it fixed, then selling it. An 02 C230 coupe is not a car I would ever recommend owning.
mr.xpowerseller is offline  
post #6 of 8 (permalink) Old 08-18-2010, 05:00 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,450
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
Dead batteries seem to upset M-Bs from the past 10 years... See this recent thread on a W209 CLK.

http://www.benzworld.org/forums/w209...d-battery.html

Also, unlike cars of yesteryear, a low battery will not be heard struggling to start your car. If the battery terminal voltage is insufficient, the 'Drive Authorization System' will not allow the start sequence to move on.

However, you heard a click. This might be the solenoid closing, but with insufficient voltage, the starter will not move. You probably need a new battery, and also a check that your alternator is OK.
keyhole is offline  
post #7 of 8 (permalink) Old 08-18-2010, 08:10 AM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the feedback, guys.

Well, I'm getting the alternator replaced. And will either exchange the core, or see if I can have it rebuilt. This is the first mechanical challenge I've had with the C230K except for a defective cup holder, so it's been a pleasure to drive. I can conduct business in Boston, then open up the sunroof and windows and head to Cape Cod and relax.

Thanks again for taking the time to write in and help me get a handle on the alternator/battery situation.

Maybe I'll add one last comment once everything is back to normal!
AllstonRocks is offline  
post #8 of 8 (permalink) Old 10-25-2011, 07:50 PM
BenzWorld Newbie
 
Date registered: Oct 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
So was the alternator the issue?
haelhady is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Battery Dead - how long should a battery stay charged when the car sits? zayman C208/A208 CLK-Class 10 03-27-2010 06:34 PM
    Motor just died - reason mustang W126 S,SE,SEC,SEL,SD,SDL Class 0 12-03-2009 04:27 AM
    charged battery now problems samsongee C208/A208 CLK-Class 6 05-16-2006 11:00 PM
    Key fob battery died, is battery replacement covered under warranty? S4toML W163 M-Class 2 07-13-2004 09:14 AM
    anyone have starting problems? My car died twice today after starting... cgeorge430 W163 M-Class 10 08-03-2002 11:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome