Error with Engine coolant temperature signal read by CFI control module - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-17-2010, 08:07 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2009
Vehicle: '92 300E, ~200K miles
Location: High Point, NC
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Error with Engine coolant temperature signal read by CFI control module

So my check engine light on my 92 300 E went on the other day, and I'm lucky enough (or unlucky) to have the California model with built in LED on the OBD system. I read the fault codes (3, 28, 29) which seem to indicate the following:

(3) Engine coolant temperature signal read by CFI control module

(28) Intermittent contact in engine coolant temperature sensor circuit

(29) CFI and ignition control module reading different engine coolant temperature

It sounds like a loose wire possibly, but, I'm looking for some advice before I just start diving in and mucking around without having a sense of where to start. I replaced the Engine Temp Sensor (attached to the block of the engine near the back wall of the engine compartment) about a year ago, without issue. Any thoughts?

Thanks in advance.
WolfeFin is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Seats ESA control module signal to CAN bus questions 000-668 W210 E-Class 1 08-17-2010 09:22 AM
Code 11, Tn-signal (rpm signal ) at engine control module faulty ocampg W124 E,CE,D,TD Class 2 06-11-2010 07:23 AM
Engine coolant temperature sensor D4LJE W124 E,CE,D,TD Class 2 03-29-2010 10:41 AM
Engine Coolant Temperature Circuit Malfunction xhino87 W140 S-Class 6 01-15-2010 03:53 AM
Error Signal (Yellow Engine) pdiddy26 W211 E-Class 1 02-29-2008 04:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome