1997 C-Class with Electrical malfunctions - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-14-2010, 06:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1997 C-Class with Electrical malfunctions

I have been having problems with the electicial circuits and I am not gettting any help from my dealership in town. These malfunctions come and go. It started with these things in this order. 1. Turn signals (sometimes they work sometimes they do not). 2. Next came the brake light in back window (sometimes it works, sometimes not). 3. Winshield wiper sometimes comes on when you start car. It will not go off, till I turn car off and start it again. Any ideas???????????

Last edited by dimercedes; 08-14-2010 at 06:28 PM.
dimercedes is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-16-2010, 07:20 PM
BenzWorld Newbie
 
Date registered: Aug 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi, Could be a faulty N10 Relay. This was the problem with my 1995 c250d. Regards Bob
BOBFAIR is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1997 E 330 Diesel electrical problem, corrected Baggy W210 E-Class 7 05-11-2016 08:08 AM
    Manual for E-Class 1997 E230 Estate johnmuni W210 E-Class 6 04-28-2008 02:18 PM
    1997 C-Class Very poor safety according to EUroNCAP SirOracle MB Safety & Testimonials 7 06-12-2006 06:36 PM
    New 1997 C230 owner--Electrical/ heater, accel problems? gopher W202 C-Class 1 01-03-2006 02:26 AM
    What are common electrical malfunctions for the W126? Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 0 02-01-2002 02:48 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome