Mercedes V220 speedo problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-09-2010, 07:14 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2010
Vehicle: Mercedes V220 CDI Auto - 2002
Location: Warwick, England
Posts: 30
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Mercedes V220 speedo problem

Hi there, I'm looking for some help ideas as to why my speedo doesn't work on my newly acquired V220. I've had a diagnostics carried out that states all 3 wheel sensors have gone. Is this just bad luck, coincendence that all 3x have failed at the same time or is there something else that connects them? I've checked the fuses and all appears ok, all other features on the dash appear to work and I have not other lights on the dash lit (i.e. ABS, etc). Any ideas welcome - thanks
vanillaice is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-11-2010, 08:54 AM
Forum Administrator RC Colas® & Moon Pies®
 
Digmenow's Avatar
 
Date registered: Oct 2006
Vehicle: 1981 380SL 151K: 2001 E320 4Matic Estate 147K: 2008 E350 Sport 4Matic 120K: 2005 S500 116K
Location: The Land of Pleasant Living
Posts: 36,503
Mentioned: 13 Post(s)
Quoted: 1273 Post(s)
Lifetime Premium Member
Garage
Welcome to BenzWorld Ice.

You'll probably have much better luck with your tech issues if you post your questions in the V-Class forum. Follow the link below.

V-Class

Also, why not take a minute to go to the User CP at the top of this page and fill in a bit of your profile with your car's info and location (generally) to make it easier for the other members to assist you.

Thanks and good luck with the car.

Quis custodiet ipsos custodes?

Digmenow is offline  
post #3 of 4 (permalink) Old 08-13-2010, 05:43 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2010
Vehicle: Mercedes V220 CDI Auto - 2002
Location: Warwick, England
Posts: 30
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Thanks for the advice, updated my profile and moved this thread to the V220 forum.
vanillaice is offline  
post #4 of 4 (permalink) Old 08-22-2010, 11:51 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Mercedes V220 AmoS500 V-Class 6 03-01-2010 02:04 PM
    V220 Suspension Problem Again raynebowman General Mercedes-Benz 0 01-31-2009 03:13 PM
    v220 front wheel problem help cav turbo wigan V-Class 4 10-14-2008 05:20 PM
    mercedes vito 110cdi speedo problem. cabdriver Audio & Telematics Forum 0 08-17-2008 05:55 PM
    Mercedes V220 Help On Seats :) Pindy V-Class 2 08-10-2006 01:37 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome