Hey - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-05-2010, 11:35 AM Thread Starter
BenzWorld Newbie
Date registered: Aug 2010
Vehicle: 1984 Mercedes Benz 190E, manual transmission.
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Hey everyone, I'm new here so I figured I should post.
The car actually belongs to my boyfriend; he's originally from NC. We live in the Pittsburgh area right now, though.

We have a 1984 Mercedes 190E. It's a gas powered manual.

Got the car back from the shop yesterday and they said it was unsafe to drive. That's why I'm here, I guess! I need to figure out how to fix this thing, at least what I can do myself, because money is hard to come by these days.

They said it needs new inner tierods, belts, rear shocks, right front strut, brakes, tires, wiper, shifter bushing on transmission, and the parking brake isn't working.

They also said that there's an oil leak on the engine, however the oil line hasn't ever dropped dramatically. They also said that the rear end was leaking. We asked them what they meant like that and they said that the "pumpkin" was leaking. We asked again, and the lady pointed out the differential to us, and my boyfriend asked "you mean the differential?" and she was like "uh..the pumpkin!"

They also said that the rear rotors were rusty. However, when looking at them last night they seemed fine. My boyfriend suggested that it was rusty because we've used the car twice in the past 8 weeks.

so yeah...fun times at the shop!

We're going to try to do the best we can to cut down on costs.

Just picked up the chilton's guide today, so we'll see how it goes.

Nice to meet you all!
Ducttapewontdo is offline  
Sponsored Links
post #2 of 2 (permalink) Old 08-15-2010, 08:50 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Hey hey - 2009 C300 Sport SkeeterM General Mercedes-Benz 2 08-10-2009 10:42 AM
    Hey Hey! A DIFFERENT problem with the ML55 Heat/AC! Loudgoldwing W163 M-Class 1 05-06-2009 10:49 AM
    Hey....Hey NEOKEN...What a way to shart 2009..... Qubes Off-Topic 1 01-02-2009 05:25 PM
    Hey, Hey....Bay area / San Fran folks.... JimB W163 M-Class 13 06-24-2003 12:00 PM
    Hey Hey Hey, Can we say Happy Birthday to our Master;-) JimB W163 M-Class 6 04-25-2003 06:57 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome