2000 ML430 - CEL and Radiator Light - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-03-2010, 06:24 PM Thread Starter
BenzWorld Newbie
Date registered: Aug 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2000 ML430 - CEL and Radiator Light

I have a 2000 ML430. About a month ago, the radiator light on the dash came on. Since then, it will turn on and off sporadically, usually for 15 minute intervals. I notice that each time the light comes on, the AC stops blowing cool air. Additionally, the light seems to come on when the car has been driven for extended periods of time or when it is extremely hot outside (100 degrees +). Also, the engine temperature gauge completely drops to the bottom and the exterior temperature stops reading correctly.

The second problem is the CEL came on. I had it read and received the following codes: P0170 and P0173. I've read that these codes indicate a problem with the MAS. I pulled the MAS out and cleaned it out with some solution. Is there a way to clear the CEL codes without taking it to a dealer (ie disconnecting the battery)? Also, the car seems to rev a bit higher at times and feels a little sluggish.

Any help would be appreciated. Thanks in advance.
danny.koss is offline  
Sponsored Links
post #2 of 2 (permalink) Old 08-04-2010, 02:09 PM
BenzWorld Elite
Michael Pillay's Avatar
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,273
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
What solution did you use to clean the MAF? To clear the CEL, you can disconnect the negative terminal of the battery for a few minutes. You will have to enter the radio code once you reconnect the battery.

Are you low on coolant? My w163 does the same thing when it is really hot. There was a discussion on the w163 forum awhile back. If you do a search I bet you would find it.

Michael Pillay is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    How-To/DIY for replacing radiator in 01 ML430? wjbarton W163 M-Class 23 03-11-2014 09:51 AM
    Will 2001 Ml430 transmission work in a 2000 ml430? orlandotrader W163 M-Class 3 02-24-2006 04:31 AM
    im installing a fog light on my 2000 ML430 i need to know how i can hook the wiring. cueto W163 M-Class 2 04-11-2005 08:20 PM
    How to Reset my check engine light 2000 ML430 RDM77 W163 M-Class 2 04-08-2004 11:28 AM
    2000 ML430 climate control dials light bulb. AlexG W163 M-Class 2 11-01-2003 05:56 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome