rumbling noise from please - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-31-2010, 02:21 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post rumbling noise from please

have a 2004 Benz c240 4 matic (60,000 miles) just had new struts and cv axle boots replaced. now when I picked the car up it makes a funny click noise when you shift it from reverse to drive. when you drive off no problems and silent. but when you stop at an light the car has this rumbling feel coming from the floor and side of floor console.

I asked my mechanic do you hear that noise he told me I was crazy that he doesn't hear nor feel anything.. I think he is taken advance of me as this is the only Mercedes that I have had to bring back to have different things fixed. I went to dealer who cant look at it until next week ugh . but he says that it is most likely a heat shield? how would a heat shield make not only a rumbling sound like it was idling high but the clicking when you shift from drive to rev. if you put it in N or P no noise (clicking) nor rumbling????? I'm lost, please help.

thank you
pimpinbenz is offline  
Sponsored Links
post #2 of 3 (permalink) Old 07-31-2010, 02:30 PM
Outstanding Contributor
keyhole's Avatar
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,353
Mentioned: 9 Post(s)
Quoted: 343 Post(s)
Did they remove the exhaust system when they did that last job?

It could be that the pipes are not quite aligned, and one is just touching the chassis somewhere. I've had this happen on other (not M-B) cars.
keyhole is offline  
post #3 of 3 (permalink) Old 07-31-2010, 02:51 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post rumbling

no exhaust was touched from what i know, the car went in to have new struts on front installed and at same time have the CV axle boots replaced. he took apart the front of the car both CV axle drive shaft axles some people call them, they didn't need to be replaced nor rebuilt, just the inner and outer boots had to be replaced. the mechanic installed the new struts along with the above mention CV axle boots and he did say that one sway bar that attach's to the strut he had to replace. now I just get car back and thinking great it all set. only to have this strange rumbling sound and feeling. drive great and all but the rumbling and the click noise when you shift it from reverse to drive is driving me crazy ha-ha.

to be honest i think my mechanic doesn't know his azz from his head. seems every-time i have him fix one thing when i pick it up something else is wrong. example the mechanic took over 3 months to find struts the joke even after 3 months when he thought he had the right strut and my car ripped about he calls me to tell me that they don't fit, i had to call the dealer and have them over night struts to him. and on top of it my mechanic kept telling me it was a sports suspension which guess what wrong ..its doesn't have a sports suspension..great mechanic huh lol.. time 4 me to replace
pimpinbenz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Weird rear end rumbling noise surucity C209/A209 CLK-Class 1 04-07-2010 03:04 AM
    Rumbling noise in the Right Rear- not all the time moms c280 W202 C-Class 0 12-10-2007 06:02 AM
    Rumbling noise - advice needed! chicomerc W210 E-Class 3 03-25-2006 08:39 AM
    weird rumbling noise during idel Kenny4454 W202 C-Class 1 07-08-2004 12:58 PM
    '99 C280 Rear Rumbling Noise mercho W202 C-Class 3 10-28-2003 12:36 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome