Hello Benz owners! Please help. - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-29-2010, 11:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello Benz owners! Please help.

I have 1998 e320, it would stall and after waiting for few minutes it'll start but after going for few blocks it would stall again. No check engine light would come on. Replaced crankshaft position sensor after reading this forum. Still doing the same thing. Today it got worse, it only started after waiting for couple of hours. Not getting any voltage at the fuel pump when trying to start it (fuel pump fuse is OK). Something is preventing power from going to fuel pump ocasionally.
Dima89 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-01-2010, 11:39 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is online now  
post #3 of 4 (permalink) Old 10-30-2010, 03:07 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Dima89 View Post
I have 1998 e320, it would stall and after waiting for few minutes it'll start but after going for few blocks it would stall again. No check engine light would come on. Replaced crankshaft position sensor after reading this forum. Still doing the same thing. Today it got worse, it only started after waiting for couple of hours. Not getting any voltage at the fuel pump when trying to start it (fuel pump fuse is OK). Something is preventing power from going to fuel pump ocasionally.
It was just a fuel pump relay located inside fuse box under rear seat. Radio shack price is around $7. Just need to trim plastic sticking out. To find a problem, I pulled out relay, took cover off, put relay back and pushed contact with a finger (don't worry its only 12 volts, you will not get shocked), I heard fuel pump going, at the same time I reached for the key and tried to start a car, it started right away. As soon as I let go the relay, engine stalled. It has been few months now, engine never stalls. Replacing crankshaft position sensor was waist of money.
Dima89 is offline  
post #4 of 4 (permalink) Old 10-30-2010, 05:05 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    New used benz owners in Arizona pjmoraldo General Mercedes-Benz 2 05-03-2010 07:14 AM
    Hello Benz Owners OleChunky General Mercedes-Benz 1 02-22-2009 08:33 PM
    detroit benz owners RickASolis W126 S,SE,SEC,SEL,SD,SDL Class 1 01-13-2009 05:35 AM
    What DO Benz owners want? Check Codes W210 E-Class 9 05-22-2008 02:09 PM
    For all you black Benz owners vinny70 W203 C-Class 6 05-17-2004 07:32 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome