2003 C240 4matic Troubles - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-15-2010, 07:53 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2010
Vehicle: 2003 C240 4matic
Location: Washington State
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 2003 C240 4matic Troubles

I own a 2003 C240 4matic. Returning home from a trip to Montanta (I live in centreal Washington) the Check Engine light came on. Shortly after the check engine light appeared I noted puffs of white smoke from the exhaust. We were only about 30 miles from home so we continued home. Upon arrival home, lots of white smoke was coming from the exhaust and the engine was running very rough.

I have hooked the car up to my OBD2 reader and have misfire codes in cylinder 1,2&3 and a multiple misfire code.

I have some engine work experience on less complicated older vehicles but I am thinking I have a blown head gasket. However, before I start the tear down I was wondering what others thought?? Maybe I am missing something and it is not the head gasket (I think this is just some wishfull thinking on my part).

Thanks in advance


Last edited by Jim9514; 07-15-2010 at 08:00 PM.
Jim9514 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2003 c240 4matic tranny service needed?? contact148 W203 C-Class 1 01-27-2010 09:19 PM
    2003 c240 4matic useing coolant contact148 W203 C-Class 0 12-08-2009 05:14 PM
    2003 C240 4matic question RDM3 W203 C-Class 0 09-14-2009 07:06 PM
    What kind of brake fluids does my 2003 c240 4matic need? dg45 W203 C-Class 1 08-14-2009 12:36 AM
    Just purchased a 2003 C240 4Matic with 30k miles. silvershark W203 C-Class 9 10-18-2007 10:49 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome