Hi all - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-13-2010, 06:09 AM Thread Starter
BenzWorld Newbie
Date registered: Jul 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi all

Hi there. I'm a new member. I'm Erik Coleman, from Northern Ireland, United Kingdom. I am the proud owner of a 2002 E320 CDI. I've joined this site to obtain help. The LCDs in the instrument cluster are pixelated. I've been told that I need to fit little wedges on the ribbon cable in the instrument cluster, and I have done this, but it hasn't improved things. Can anyone, who has successfully done this, send me some photos, showing their wedges in place? Secondly, when stomping on the throttle pedal, there is a serious lag - and sometimes it requires 2 or 3 stomps to get the car to kick-down and go. My local dealer says this is a common problem, but doesn't know how to fix it, as the diagnostic computer isn't listing any faults. Again, I'd be most grateful if someone can give me helpful advice. Cheers...... Erik.
ErikNI is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-24-2010, 08:29 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome