Benz Speaker System Very Odd Problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-05-2010, 01:43 AM Thread Starter
BenzWorld Newbie
Date registered: Nov 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Benz Speaker System Very Odd Problem


I own a 2004 Benz C230 Kompressor Sport with a standard Bose sound system. A couple of weeks ago as I was listening to music, suddenly the sound cuts out and these weird crackling, booming and humming sounds start emanating from the speakers, sometimes from multiple speakers at once and sometime in succession starting from the font and migrating to the back ones. When I turned off the radio the sounds continued. Then the next day everything returned to normal and then it happened again just as I was pulling into a parking spot. I turned the car off, but the noises continued. I have absolutely no idea what may be happening, right now the last time it happened, there is just a continuous humming and whining sound that appears to rise in pitch as I accelerate. This has been really baffling as I cannot find any information in regards to this problem.

Thanks in advance.
shablya is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Odd Benz Pics. BossBenz W126 S,SE,SEC,SEL,SD,SDL Class 6 11-16-2009 08:02 PM
    Odd problem with my HVAC system...maybe you could help? W140FTW W140 S-Class 1 01-04-2008 11:59 AM
    Extremely odd electrical system problem while driving bmustaf W164 M-Class 19 08-27-2007 06:33 PM
    very odd problem on an old 124 sedan. parking lights put voltage on the speaker line speedy72t Audio & Telematics Forum 0 03-22-2007 04:17 PM
    odd coloured benz beamerbenz W123 E,CE,D,CD,TD,TE Class 3 12-17-2005 10:02 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome