Merc w210 will not start after storage period - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-03-2010, 07:29 AM Thread Starter
BenzWorld Junior Member
Date registered: Jul 2010
Vehicle: '00 Mercedes E200K W210 Elegance
Location: Waterford, Ireland
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Merc w210 will not start after storage period

Hi I'm new to this forum though I have owned my E200k (manual 6 speed) for the last seven years and 220k miles. Great car. Due to being made redundant the car has been out of service for the last 3 months and during that period the battery has died completely. I have just fitted a new battery and tried to start the car but to no avail.
When the key is inserted it activates (I can hear the usual buzz) and the key switches on the ignition, lighting up the various warning lights. However, when turned to start, the starter will not work, also the fuel pump does not work, (there is no fuel pressure at the rail). All fuses have been checked in the engine bay, under the back seat and also beside headlamp switch and found to be ok.
I have plugged in a diagnostics unit to the 38 pin socket but it shows a communication error stating ignition should be "on", though it already is.
It looks like there is no power to the ecu / ignition system. I have also tried towing the car a short distance and noticed that with the engine turning the rev counter is not registering, again maybe due to no power to ignition system to generate spark pulse.
The car was running perfectly before being parked up.
Has anybody else had any experience like this or is there anybody out there that can help?
johnm311 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-11-2010, 03:36 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Long term storage start up? Joe88 W126 S,SE,SEC,SEL,SD,SDL Class 6 01-10-2009 12:27 AM
    Proocol before first start from storage- Priming? The Melmaan W201 190-Class 3 09-16-2008 11:13 PM
    How to start up 220D after long term storage coastie47 Vintage Mercedes-Benz 4 04-15-2005 01:28 AM
    Loud clicking, won't start after winter storage. saxmanjack R170 SLK-Class 2 03-16-2003 05:48 PM
    Winter storage...cycling start.. Carlos c/o Frank R170 SLK-Class 8 12-06-2000 08:21 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome