'83 300TD turns, doesn't start - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-22-2010, 07:19 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
'83 300TD turns, doesn't start

Hi all, I bought this car on Sat with 220k miles. What I wasn't informed of until after I paid was that the car was sitting for at least two years. Anyway, it started like a charm the first time (I made sure the engine was cold when I tried) and I drove it back to my house (about a 2 hour drive, car started off really slow, even for a diesel, but after about 30 minutes, it ran great).

After letting it sit overnight, the car would not start the next morning. It turns but nothing else. I searched some of these forums, used the manual fuel pump, and viola, it started. So I was thinking that it is a fuel problem. So, I replaced the fuel filters, changed the oil, replaced the oil filter, checked all fluids. Again, the car wouldn't start. I used the manual pump again (to make sure there was no air in the lines), the car started. I again let it sit overnight, and this AM the car would not start.

I am going to replace the glow plugs (the light on the dash goes out after about 5-10 secs so I don't think they are broken). What else do you think could be a problem? I don't really know how to check the compression but, I got the car to also learn how to fix it on my own.

All help is appreciated!
thh204 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-22-2010, 07:45 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,515
Mentioned: 9 Post(s)
Quoted: 1059 Post(s)
Don't replace glow plugs without testing them bad.
Your description clearly indicate that you have leaks in fuel lines and overnight the air enters the system.
What first time diesel owners don't realize is that fuel system on those engine runs on vacuum till it reaches the pump. Meaning leak will not show as a fuel outside, but as an air inside.
Make sure all the fuel connections are in good condition. From my memory you engine has connectors with copper washers. You might want to buy new ones and replace them. Also there is a clear tubing on the line that allows for observing air bubbles. If it turned brown -it would be good time to replace it as well.
Good luck and welcome to the forum.
Kajtek1 is online now  
post #3 of 3 (permalink) Old 06-22-2010, 08:25 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, Kajtek. I will check out those lines. I know for a fact that there is a leak in one of the fuel lines. As I was replacing the secondary fuel filter, I noticed that one of the tubes was in pretty awful condition (gashes in the tube). After I restarted the car, a sizeable leak appeared in that tube.

Do I have to specially order that tubing, or can I get it from an Advanced Autoparts store? (Or could I even order it from somewhere like McMaster?)

Thanks for the info!
thh204 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    300d turns over, but no start. jessesaur W123 E,CE,D,CD,TD,TE Class 63 01-17-2010 02:42 PM
    '84 300TD stalls after turns - only on highway MarieGraham W123 E,CE,D,CD,TD,TE Class 9 07-07-2009 06:56 AM
    300 E turns over but won't start Ann Harrison W124 E,CE,D,TD Class 10 07-30-2008 07:06 AM
    300 E turns over but doesn't start Ann Harrison W124 E,CE,D,TD Class 2 07-27-2008 07:05 PM
    Always two turns to start Guest (MBNZ) W124 E,CE,D,TD Class 3 07-02-2002 09:54 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome