S500 Speedo and fuel consumption gauge problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-20-2010, 04:43 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Vehicle: S500 Coupe 1994
Location: Edinburgh, Scotland
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S500 Speedo and fuel consumption gauge problem

Hi Folks,

1994 RHD S500 Coupe.

My speedometer started jumping all over the place for about a week then stopped working altogether. The Odometer has also stopped along with the Fuel Consumption indicator gauge.

Any ideas what has gone faulty to cause this?

Thanks

Douglas
MrImpulsive is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-20-2010, 07:43 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,687
Mentioned: 11 Post(s)
Quoted: 404 Post(s)
Speedo signals are derived from left/right rpm sensors located near front wheel rotors (discs). Can be disturbed in error when brake servicing is performed.

Without speed signal, odometer & fuel consumption calculations will not be performed. Also cruise control, if fitted.
keyhole is offline  
post #3 of 3 (permalink) Old 06-20-2010, 08:02 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Vehicle: S500 Coupe 1994
Location: Edinburgh, Scotland
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, for that info! I also just read about some additional fuses at the rear of the engine compartment where you have to undo 4 Allen keys to get at them and one of these also seems to have links to these items so I will check this too!
Many thanks

Douglas
MrImpulsive is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Is fuel consumption gauge from 1992 S500 same as from 1994 S420? samosali W140 S-Class 4 06-09-2010 06:28 AM
Gas gauge not registering correct fuel consumption? bbearden26 W163 M-Class 4 07-29-2007 08:40 PM
No Speedo, Tach, or Fuel Gauge gmabli R171 SLK-Class 6 03-21-2006 03:03 PM
fuel consumption gauge help please crane W140 S-Class 9 01-13-2006 07:40 AM
inoperative speedo and fuel consumption gauges WKGS320W14095 W140 S-Class 4 01-12-2006 04:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome