C320 shaking at idle and turns off - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-16-2010, 11:24 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
C320 shaking at idle and turns off

I started having this problem with my 2002 C320 about 2 weeks ago. The car started shaking at idle. Then the shaking started happend while driving it. It felt like the car was going to die and I was not able to pick up any speed when stepping on the gas. About 2 days ago I was driving to work, check engine light came up and the car died. I restarted it and was able to drive back home, it died a few times in like a 2 mile drive. I left it alone and now that I wanted to take it to the shop the battery died. I put another battery but I start the car it shakes a bit and then turns off. Any help with this would be appreciated.
totisleon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-16-2010, 03:01 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Quote:
Originally Posted by totisleon View Post
I started having this problem with my 2002 C320 about 2 weeks ago. The car started shaking at idle. Then the shaking started happend while driving it. It felt like the car was going to die and I was not able to pick up any speed when stepping on the gas. About 2 days ago I was driving to work, check engine light came up and the car died. I restarted it and was able to drive back home, it died a few times in like a 2 mile drive. I left it alone and now that I wanted to take it to the shop the battery died. I put another battery but I start the car it shakes a bit and then turns off. Any help with this would be appreciated.
Welcome to the forum.

First things first: please complete your BW Profile:


As to your immediate issue, shaking sounds like it is shutting down cylinders which is pretty serious. It could also be the Crank Position Sensor, a relatively inexpensive part that is simple to change.

If you've been ignoring maintenance this could get expensive, but the place I'd probably start is reading the codes. If you don't want to take it somewhere buy a cheap code reader (Amazon has one for $40) and get the codes, that will point you in the right direction.

Also, please note that you posted in the general forum. You're much more likely to get help on a specific issue by posting in the forum that is specific to your car, the W202. Scroll down and you'll see it in the sedan section.

Good luck.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 3 (permalink) Old 06-16-2010, 04:18 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the reply. I will definitely post at the right place next time. The Crank Position Sensor was replaced last summer and I alway do the services on time. Im going to buy the code reader and go from there.

Thanks,
totisleon is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Shaking at idle orlandotrader W163 M-Class 8 03-14-2011 04:57 PM
    SL engine 'shaking' at idle clipster R129 SL-Class 15 05-19-2009 01:16 AM
    Idle Shaking garrettsmith W123 E,CE,D,CD,TD,TE Class 4 11-13-2006 10:52 PM
    Shaking engine while idle jf23668532 General Mercedes-Benz 1 06-28-2005 06:03 PM
    shaking at idle while in "D" FIXED!!! snik W124 E,CE,D,TD Class 24 03-31-2005 07:59 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome