2006 C230S - Transmission "Valve Body" cracked - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-15-2010, 01:55 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2006 C230S - Transmission "Valve Body" cracked

*Was urged to post this in a "newer" forum, not sure if this is the right place, but here goes. Mods, please let me know if this is a problem)

Dad purchased a 2006 C230 Sport brand new, and since about 6-8 months ago we've been having an issue with the transmission. To sum up, the engine simply does not switch gears properly, and often stays "stuck" on 1st or 2nd gear when driving. The "check engine" light has also come on a few times. Figured that it was just in need of a transmission flush, so I brought it into service. After taking it into service, I was told that the issue is that the "valve body" in the transmission is cracked, as a result of hard upshifts or downshifts.

What stumps me is the following:
-The car has NEVER been driven hard at all, always on "D." We never used the "tiptronic" shifting capability.
-Car is now out of warranty, so we're being quoted $2K+ to fix this issue
-Car has been babied, and all the usual normal service has been done at the *gulp* dealership... no problems were noticed before.

What I wanted to see was if anyone else had a similar problem like this? Even the service guy told me that this is an extremely RARE issue, and I'm beginning to wonder if it's due to a defect...

Any helpful thoughts would be appreciated, especially if someone has had a similar issue.
niceaznguy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-15-2010, 02:35 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hey niceaznguy

Hey niceaznguy,
Can you be more specific on what kind of car? There are 3 versions of C230 kompressor coupe, sedan, or just regular c230. There are two types of trans in this car 722.6 and 722.9 trans. Now i do have both in stock and if i stock them then yes it is very common for both. I have sold six in the last 2 months. Now as for the price of 2k sounds about right. Now we sell it for less but the average of list price on parts at a dealership $1450.00 and labor about 4hrs at average labor rate at $120.00 x 4 =$480.00. You really can't do it yourself because they have to program your valve body to the tranny.

Last edited by MBNANUET1; 06-24-2010 at 07:49 PM.
MBNANUET1 is offline  
post #3 of 3 (permalink) Old 06-15-2010, 02:55 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
yeah, that's what i've been quoted thus far.

it's a 2006 C230 Sport Sedan.
niceaznguy is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Help with 2006 C230 Sport Issue- "Valve Body" cracked niceaznguy W202 C-Class 2 06-15-2010 01:52 PM
    LS-190 **400hp "16 valve" V8 Build With Pics** Gen3Benz W201 190-Class 38 06-29-2009 11:25 AM
    Will the "Plumbing Valve" work with a 300CE (24v engine)? Erwin8r W124 E,CE,D,TD Class 0 09-08-2006 10:21 AM
    2003 E320 Transmission Question ( "C" or "S") setting jmorgis W211 E-Class 3 11-06-2003 02:05 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome