loss of power on e320 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-14-2010, 02:33 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry loss of power on e320

could you please help i have loss of power on a 5 yr old e320 from 1st to 2nd gear.It is automatic and i have to change to manual. Have had it in twice to two diff garages,help.
christine s is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-14-2010, 02:39 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
What have you tried and what codes is the STAR giving you?
mr.xpowerseller is offline  
#3 (permalink) Old 06-14-2010, 03:32 PM
BenzWorld Newbie
 
AMG1515's Avatar
 
Date registered: Jun 2010
Vehicle: 2003 E320
Location: Washington DC
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to AMG1515
Did anyone say it was the catalytic converter(s)?
AMG1515 is offline  
#4 (permalink) Old 06-14-2010, 03:38 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by mr.xpowerseller View Post
What have you tried and what codes is the STAR giving you?
what do you mean, the star
christine s is offline  
#5 (permalink) Old 06-14-2010, 03:40 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by AMG1515 View Post
Did anyone say it was the catalytic converter(s)?
no catalytic converter not mentioned
christine s is offline  
#6 (permalink) Old 06-14-2010, 03:59 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by christine s View Post
what do you mean, the star
Did you bring it to Crappy Lube for service or what? Your mechanic should have plugged the car into a STAR Mercedes diagnostics computer, which can access all the sensors on the car and narrow down exactly where the issue is at. It saves the labor time of having to pull the transmission apart when the issue may be somewhere else. You need codes to narrow down the problem. Without them, you are sailing blind.
mr.xpowerseller is offline  
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2001 e320 cdi - loss of power/vibrations? cuebandave W211 E-Class 0 04-13-2010 05:35 PM
power loss bobstack W211 E-Class 7 10-09-2009 09:33 AM
Power Loss klevert W163 M-Class 5 05-29-2009 04:58 AM
Loss of power mogtract Unimog 4 08-09-2007 10:45 PM
Power Loss davey W201 190 Class 4 07-26-2003 03:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome