Radiator Fan wont turn off!! Help! - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 06-07-2010, 04:56 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to wf.1990
(Thread Starter)
Angry Radiator Fan wont turn off!! Help!

hello guys! i started my car today after a tranny ATF change, when the Radiator fan in my clk320 turned on and wouldnt turn off.

So whilst still at the shop, he pulled some codes using STAR..it turns out the fan itself was defective, so he changed it with a replacement spare he had..

Still the radiator fan spinned like crazy sounding like jet engine, he also replaced the driver side SAM and a little rectangular metallic box on the driver side front bumper (sorry i dont know wat its called)..and nothin helped!!

no fault codes on the ecu (current or stored)..and the fan would only turn off when i turn the engine off..thanks in advance guys and sorry for duplicating this thread but i thought it would also be relevant in this forum..cheers!!
wf.1990 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 06-08-2010, 04:22 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to wf.1990
(Thread Starter)
anyone?!:S please ive been at 4 mechanics so far and no one could solve it!!

its extremely annoying to have your car sounding like a jet engine all the time!:@

so please, i know you guys are one of the most experienced people in the world when it comes to mercedes, can anyone just help diagnose this problem? thanks guys..
wf.1990 is offline  
post #3 of 15 (permalink) Old 06-08-2010, 05:25 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
So the car was diagnosed and some fault codes appeared but you do not know which ones? Do those codes still appear or did they go away when cleared or when the SAM and (likely) the fan control unit were replaced?

I would follow the wiring diagram from the fan backwards down to the AC control unit and see where the drive signal comes from. Did you try to disconnect the AC control unit?

Which ECU do you mean when you say "no fault codes from the ECU"?
Diesel Benz is online now  
post #4 of 15 (permalink) Old 06-08-2010, 05:39 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to wf.1990
(Thread Starter)
Well first of all, thank you for repliying..

Secondly,we know what the codes stand for, and one was for the fan itself...so thats what made us change the fan..but it didn't work..so he changed that small rectangular metallic bit which im presuming is the fan control unit...

well we disconnected the ac control unit inside the vehicle, we started the car, but the fan still turned on, even though on the DAS it shows the the auxillary fan is being demanded at an output of 94% by the AC control unit..and i meant the ecu which is in the passenger side black box..is it possible that its a relay problem?
wf.1990 is offline  
post #5 of 15 (permalink) Old 06-09-2010, 03:39 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It sounds like there is a fault in the wiring or a relay that controls the fan and/or communication with the HVAC control module. When this happens, the ECU will often times put the fan into safe mode (always running) to avoid an overheat or melt down.
mr.xpowerseller is offline  
post #6 of 15 (permalink) Old 06-09-2010, 05:12 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to wf.1990
(Thread Starter)
Quote:
Originally Posted by mr.xpowerseller View Post
It sounds like there is a fault in the wiring or a relay that controls the fan and/or communication with the HVAC control module. When this happens, the ECU will often times put the fan into safe mode (always running) to avoid an overheat or melt down.
Oh ok, but we disconnected the Air con control module (the panel in the middle console inside the car) but that didnt solve anything...

Is it true that there are no relays for the fan exect the fan control unit which is located next to the radiator? If there is how can i find them? Is it possible my ECU is damaged? Thanks in advance
wf.1990 is offline  
post #7 of 15 (permalink) Old 06-10-2010, 02:08 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If you disconnected the HVAC control module then you put the fan into safe-mode. The ECU thinks there is a fault in the system, so its turning the fan on. Can you check to see if the A/C compressor is cycling on/off as needed or is it always running? Is the A/C bringing the vent temp down to +/-40 degrees with exterior temp being 70-80?
mr.xpowerseller is offline  
post #8 of 15 (permalink) Old 06-10-2010, 02:28 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to wf.1990
(Thread Starter)
Well, the hvac is cooling perfectly, and we disconnected the hvac control unit as a part of the diagnostics, the fan problem was already existent when we disconnected it.

I also just remebered, the fan was fine when we changed the fluid, but then we replaced the MAF, turned it on, the turned it off, put it on star..reset the faults..then turned the car again, when the fan problem emerged..

Could it be related to us replacing the MAF and reseting the codes on star? Thanks for your help!
wf.1990 is offline  
post #9 of 15 (permalink) Old 06-10-2010, 02:38 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to wf.1990
(Thread Starter)
Oh and one more thing, if I start he car on a cold start, the fan stays about 1 minute to turn of..hope that helps for something!
wf.1990 is offline  
post #10 of 15 (permalink) Old 06-10-2010, 02:39 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by wf.1990 View Post

Could it be related to us replacing the MAF and reseting the codes on star? Thanks for your help!
No, it shouldn't have anything to do with that. The fan should cycle on/off with your A/C compressor. That is why I asked if the compressor is running non-stop or what is going on. This could be related to your compressor or low refrigerant or the sensor that tells the fan to turn on/off based on R-134a pressure in the system.
mr.xpowerseller is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Radiator Fan wont turn off!! Help! wf.1990 C208/A208 CLK-Class 17 10-22-2012 01:02 PM
    doors / boot wont lock - key wont turn alberto28 W202 C-Class 0 05-16-2010 01:33 PM
    MERCEDES BENZ CLK 320 Coupe 1999 Need Radiator Fan Shroud+Fan Blade kri7ek General Mercedes-Benz 2 12-07-2009 05:01 PM
    Head gasket leveled, New Radiator, new Thermostat, New fan clutch, both Auxiliary fan Workersvillage W124 E,CE,D,TD Class 11 08-10-2008 11:32 PM
    heater fan wont turn off....... adrose R170 SLK-Class 2 10-18-2002 09:42 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome