1995 S320 suddenly no reverse? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-06-2010, 06:24 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2010
Vehicle: 1995 S320
Location: Edmonton Alberta Canada
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1995 S320 suddenly no reverse?

The reverse for my 1995 S320 suddenly quit with no warning of any kind. All other gears seem to work fine. Would anyone know if this is possibly a linkage problem or have had this strange(to me) thing happen with thier vehcle?? Any advice is appreciated as most of the so-called Mercedes mechanics in my home town seem to be more suited to working out of thier garage at home or pumping gas. This is my 3rd MB in the last 4 years and I am getting tired of paying for work on the cars that never seems to solve the original problems. I have spent more on them than I paid for them so far .
Thanks for reading and be well all.

Last edited by munefire; 06-06-2010 at 06:26 PM. Reason: rewording
munefire is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-06-2010, 07:10 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Try the W140 forum in the sedans section.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 3 (permalink) Old 06-06-2010, 08:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2010
Vehicle: 1995 S320
Location: Edmonton Alberta Canada
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Will do. Thanks very much. As you see, newbie says it all.
munefire is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1989 560 sel no reverse/slight reverse??? stalls... vectorvan W126 S,SE,SEC,SEL,SD,SDL Class 0 03-22-2010 06:53 PM
S320 V6 2001 - Front Windows & Rear Door Locks Suddenly Stopped Working selereak W220 S-Class 1 03-01-2010 10:10 AM
Different EURO S320 USA S320 JAPAN S320??????????????? pelteka W140 S-Class 2 07-20-2009 09:32 PM
no reverse / jerks in reverse when cold datpet07 W140 S-Class 30 12-11-2008 05:54 PM
1995 S320 reverse GRINDS, forward works fine......whats the problem??? artemmartinov W140 S-Class 7 07-28-2005 11:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome