Coolant & Washer Level Mystery! - Page 2 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 06-14-2010, 01:50 PM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2008
Vehicle: 2003 CLK 270cdi Avantgarde - Jasper Blue
Location: Northern Ireland
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
DB and Keyhole, have booked car in this Wed with an ex MB dealer mecahnic now working for himself, i'm told these guys are like hens teeth, all the experience and training of MB at a third of the dealer labour rate. Have checked with my private warranty folks, they'll cover exploratory diagnosis and cover fix if its sensor related, will let you know what this guy comes up with. Thanks again.
gpharper is offline  
Sponsored Links
post #12 of 14 (permalink) Old 11-29-2010, 06:57 AM
BenzWorld Newbie
Date registered: Jun 2006
Vehicle: 2003 G55, 2005 CLK320
Location: CT, USA
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Coolant & Washer Level Message - Resolution?

gpharper, did your MB mechanic ever diagnose the Washer/Coolant message issue you were having? I've recently begun having the same message on my 2003 G-55. Thanks.
DrWarmth is offline  
post #13 of 14 (permalink) Old 01-10-2011, 12:15 PM
BenzWorld Newbie
Date registered: Sep 2010
Vehicle: Citroen Xantia 1993
Location: Lithuania, Kaunas
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Mercedes w203. 2001. same problem. water level show on display. Star diagnoses in SAM module show what sensors are open, but this is not true. Before I change SAM module the fault not existed. original SAM module is Q17, now I put in Q15. What's the difference between them ? The car was without air condition. Now with air condition. So with old SAM air condition dosn't work. I think what problem is in new SAM. Ho do you think?
Mariuz333 is offline  
post #14 of 14 (permalink) Old 01-10-2011, 07:34 PM
BenzWorld Senior Member
Date registered: Oct 2010
Vehicle: '11 Santa Fe LTD V6 AWD-Navi, '99 CLK 320 (traded for family mover), '96 200SX (SOLD) :(
Location: Hanmer, ON, Canada
Posts: 528
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Just by having a quick look at the link Keyhole posted I would guess at a short to ground after the two switches as the system relies on the switches going from an open state when levels are ok to being closed when they are low bypassing the internal reference resistors in the switches. for both switches to fail is unlikely (not impossible though). The easiest thing to do first mind you is to check and make sure none of the plugs are loose or disconnected and are corrosion free.

A Benz is like a good wife: Not overly expensive to maintain, but neglected gets expensive awfully quick!
MGD is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    CLK 270 cdi - Coolant & Washer Check Warning gpharper C209/A209 CLK-Class 6 04-20-2011 10:25 AM
    low washer level and low coolant level warning lights come on and off simultaneously slicky rick W140 S-Class 8 11-04-2010 09:05 PM
    Coolant/Washer level lights Bazzle R170 SLK-Class 17 08-02-2010 09:00 AM
    low coolant light intermittent & dim but good coolant level idkmybffcms W124 E,CE,D,TD Class 4 03-14-2009 12:47 PM
    '99 S420 coolant and washer level warning lights terry9300 W140 S-Class 2 04-11-2007 10:20 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome