SRS light - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 17 (permalink) Old 06-01-2010, 05:46 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Diesel Benz View Post
Homework is always essential, even more essential when working with airbags. The light would not have come on if the battery had been disconnected while working with the steering wheel and this guidance should be easy to find.

If the battery was disconnected, then the OP could have mentioned it, every detail of background is essential when members try to help from the other side of the internet. Could be that the clock spring got broken while the OP tried to fix the horn.
Yes i did disconnect the battery.The clock spring isnt broken.I just dont understand why the light would be on but it wasnt on before. I fixed the horn(which turned out to be a bad wire going to the horn itself).
speddy is offline  
Sponsored Links
Advertisement
 
post #12 of 17 (permalink) Old 06-01-2010, 05:50 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
^Do you have a fault code reader?

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #13 of 17 (permalink) Old 06-01-2010, 06:01 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
^Do you have a fault code reader?
I had a friend at a shop check for codes.First it didnt store any codes.Then he checked it again and it said the ignition resistance to the drivers side airbag was too high.This was about 6 months ago.He cleared the codes and the light went off.It just came back on after 6 months.I havnt had it checked for codes yet.My buddy at the shop moved out of town.
speddy is offline  
post #14 of 17 (permalink) Old 06-01-2010, 06:19 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by speddy View Post
I had a friend at a shop check for codes.First it didnt store any codes.Then he checked it again and it said the ignition resistance to the drivers side airbag was too high.This was about 6 months ago.He cleared the codes and the light went off.It just came back on after 6 months.I havnt had it checked for codes yet.My buddy at the shop moved out of town.
I'm guessing the old issue reappeared because you were working with the steering wheel parts. Or you caused the issue when working with the car, I assume this being less likely.

Since you had the battery disconnected while you were working with the car, the SRS malfunction cannot have appeared because of a temporary open circuit (or short circuit). Sounds like a "real" issue that needs to be fixed, not just a code cleared.
Diesel Benz is offline  
post #15 of 17 (permalink) Old 06-01-2010, 06:29 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Diesel Benz View Post
I'm guessing the old issue reappeared because you were working with the steering wheel parts. Or you caused the issue when working with the car, I assume this being less likely.

Since you had the battery disconnected while you were working with the car, the SRS malfunction cannot have appeared because of a temporary open circuit (or short circuit). Sounds like a "real" issue that needs to be fixed, not just a code cleared.
Thanks.I'm gonna take it to the shop.I just hope it doesnt cost an arm and a leg.I'm sure it will though.Its a Mercedes ,lol.
speddy is offline  
post #16 of 17 (permalink) Old 06-01-2010, 06:45 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2004 Mercedes C240 4matic
Location: Connecticut
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I just spoke to a mercedes tech.He's telling me the most likely cause might be the ignition squid.Anyone know anything about "ignition squids".How hard are they to replace?
speddy is offline  
post #17 of 17 (permalink) Old 06-01-2010, 07:41 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
Quote:
Originally Posted by speddy View Post
I just spoke to a mercedes tech.He's telling me the most likely cause might be the ignition squid.Anyone know anything about "ignition squids".How hard are they to replace?
"Most likely" is not near enough, it needs testing properly first. Or you will spend money for nothing.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    SRS light stays on and SRS DTC strange result nubyOz W140 S-Class 8 11-25-2010 10:57 PM
    srs light/ bulb failure light/ warnings darraghodonnell R129 SL-Class 5 05-10-2010 10:44 AM
    2002 c 230 check engine light and srs light upstaterider2003 General Mercedes-Benz 4 08-04-2008 08:35 AM
    ABS acting up , srs light being funny , brakes weird, oil light sometimes flashes jimmypop W126 S,SE,SEC,SEL,SD,SDL Class 11 10-03-2007 07:04 PM
    battery light to srs light dim lit my90300E W124 E,CE,D,TD Class 9 01-15-2007 07:46 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome