A/C question - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-18-2010, 10:14 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2010
Posts: 103
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
A/C question

Hi I have a question that I hope yall might be able to help. I have a 98 E320. Today my wife was driving around in the hot heat and she heard 1 loud popping sound coming from the engine. After that she noticed the A/C went out, just the fan is on. Also she notice that there is a burn smell similar to tar smell. So good folks, what can it be? Is my a/c shot? A/c compressor blown up or the belt snapped? Also if anyone can point me to a diagram of where the a/c unit is at in the engine that would be greatly appreciated.

Thank you,
Bruce Lee is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-19-2010, 03:23 PM
BenzWorld Elite
 
Date registered: Dec 2008
Vehicle: w204 (C350ELE)
Location: Miami, Fl and Mar del Plata, Argentina
Posts: 1,262
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by Bruce Lee View Post
Hi I have a question that I hope yall might be able to help. I have a 98 E320. Today my wife was driving around in the hot heat and she heard 1 loud popping sound coming from the engine. After that she noticed the A/C went out, just the fan is on. Also she notice that there is a burn smell similar to tar smell. So good folks, what can it be? Is my a/c shot? A/c compressor blown up or the belt snapped? Also if anyone can point me to a diagram of where the a/c unit is at in the engine that would be greatly appreciated.
Thank you,
The tar smell points to a bobbin, think condenser rather than belt problem...

A car would show appreciation for preventive maintenance by never leaving his owner stranded.

Defensive Driving is never having to say you're sorry: a true love story between man and machine.
JoeVal is offline  
post #3 of 5 (permalink) Old 05-19-2010, 03:24 PM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It sounds like the high pressure hose may have exploded (rare, but it can happen if stressed). If you are unfamiliar to with the car to point where you cannot identify the A/C compressor, then please do yourself a favor and bring to car a shop that can. Without seeing the car it is nearly impossible to diagnose this online. It could be so many things.
mr.xpowerseller is offline  
post #4 of 5 (permalink) Old 05-20-2010, 06:07 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Lots of info on the W210 forum, that's what you have.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #5 of 5 (permalink) Old 05-20-2010, 06:17 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
Quote:
Originally Posted by Musikmann View Post
Lots of info on the W210 forum, that's what you have.
Correct, he should re post this question here;

W210 E-Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1992 500e, Introduction, EGR Question & suspension question cars1050 W124 E,CE,D,TD Class 8 09-16-2009 08:14 PM
    instrument cluster question, A/C question, and hydraulic cylinder p/n question coolkid R129 SL-Class 3 06-22-2008 10:29 AM
    Lug bolt question, wheel paint question Alpheus W123 E,CE,D,CD,TD,TE Class 1 06-19-2008 06:58 AM
    Resetting FSS question (error code question) TheOgre W163 M-Class 7 04-25-2008 02:37 PM
    Plug and Play NAV Question.First '05 Mod Question Stewart W163 M-Class 5 11-21-2005 09:00 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome