Question about my C220 - Need An Answer - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-14-2010, 01:38 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Question about my C220 - Need An Answer

Hello all, I am new to these forums. I had a question regarding my 1995 Mercedes C220. I bought it a few days ago with about 294k on it. Car runs smoothly, no problems with the breaks, accelerator runs beautifully. The only problem I have been having is that every time I turn the car off and my lights, speaker system or anything else was still on before I turned it off, it stalls when you try to turn it on again (or even having my gas on the break pedal before turning it off) At least that's what I have noticed before it won't turn on again. All it needs it a simple boost from the booster cables after that and she's up and running again with no problems. Although not a huge problem, it is very inconvenient. Is the battery too weak to handle my speaker system?
Also, the SRS light is on, any suggestions?
A prompt answer would be appreciated.
Thanks
ilya67 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-14-2010, 02:49 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
If you don't know how old your battery is I would replace it. Or take it somewhere to have it load tested. Your SRS light might be due to a defective pad in the passenger seat cushion. On my car it inactivates the airbag on that side when a child (or someone weighing less than 70 lb) occupies the seat. A fresh battery might take care of that too.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 05-14-2010, 02:56 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
If you don't know how old your battery is I would replace it. Or take it somewhere to have it load tested. Your SRS light might be due to a defective pad in the passenger seat cushion. On my car it inactivates the airbag on that side when a child (or someone weighing less than 70 lb) occupies the seat. A fresh battery might take care of that too.
Thanks for the fast response. My battery was tested yesterday, the mechanic said the battery is super good. Could it just be that the battery is weak?
ilya67 is offline  
post #4 of 4 (permalink) Old 05-14-2010, 03:09 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
You're welcome.

Are you asking if it might have less than the required cranking amperage? That might be, check it and your owner's manual to see if it has the correct specs. Or if you can't find the info on the battery maybe a tester can tell you.

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 05-14-2010 at 03:12 PM.
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Maybe you can help answer my question? cheryl7158 General Mercedes-Benz 7 03-10-2008 04:37 PM
    Can someone answer this question? lilphatboi W204 C-Class 3 12-06-2007 11:41 PM
    No answer to this question... slknow R170 SLK-Class 8 03-01-2005 06:42 PM
    can someone answer this question? BIGGS2288 W124 E,CE,D,TD Class 6 11-29-2004 01:20 AM
    Please Answer This Question avijay Audio & Telematics Forum 4 06-25-2003 11:37 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome