C220 CDI cuts out under acceleration - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-27-2010, 01:36 PM Thread Starter
BenzWorld Newbie
Date registered: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy C220 CDI cuts out under acceleration


I have a C220 CDi 2003 that cuts out if you accelerate a little more than normal. It dies completely and EPC error comes up on the dash. Car will start straight away and will drive fine normally. Even using the cruise control stalk to accelerate will sometimes cause it to happen. If car is driven with a light foot it go on and will speed up excess of 100 mph. There is a puff of black smoke when it happens. This fault was worse at it would happen exactly at 40mph. Had the injectors out and checked with good pattern on all. They were put back in with new seals. Pump in tank taken out and cleaned. Car got a good service and this brought us to this point. I have had the high pressure pump off and swapped with a pump from from a manual C220. Car drove great for a while and same happened - died under pressure, I think because engine was cold. Gets worse as the engine gets warmer. I think myself air is getting somewhere. Any ideas, help or suggestions would be great. Car is in Ireland. Thanks, Michael.
mbyrnes is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    C200 cdi v c220 cdi are they same engine? h9llw W203 C-Class 2 01-03-2011 01:35 PM
    C220 1995 Egine Cuts out Marvins1995c220 W202 C-Class 0 04-05-2010 11:46 AM
    Egine cuts out Under Load (C220 95) Marvins1995c220 W202 C36 AMG, C43 AMG 0 04-05-2010 05:33 AM
    C220, HORRIBLE ACCELERATION AND HESITATION!! PLEASE HELP!! amgv12biturbo W202 C-Class 8 06-17-2005 10:58 AM
    '96 C220 odor on acceleration... Guest (MBNZ) W202 C36 AMG, C43 AMG 1 07-03-2002 12:05 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome