New GLK owner needs answers... - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-25-2010, 09:37 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New GLK owner needs answers...

I'm hearing some kind of loud electronic motor running on the interior of my new GLK when I insert the key into the iginition, before I crank. Lasts about 15 seconds then goes off. Doesn't do it every time. Seems to be getting louder over time. Anyone have idea what this could be?

Also in my GLK, I'm hearing some kind of electronic clicking noise in the front interior left area of the console. It is random, but very annoying. What could be causing that?

Any help/hints greatly appreciated.
wareagle03 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 04-25-2010, 05:04 PM
BenzWorld Elite
DirectLA's Avatar
Date registered: Jan 2007
Vehicle: 1962 W111 220SE Coupe
Location: Cloud City, OR
Posts: 2,289
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
You may want to post in the GLK forum to verify this, but it might be your fuel pump as they click prior to starting. If it's that noticeable it may have a problem. Someone there can tell you it's location and then you can have someone else listen in that area while you insert the key. Generally an easy fix on most cars and sould be covered if you're still under warranty.

On the electronic noise, are you using an iPod connector of some sort? Maybe interference through the audio system.


The Coupe Group (W111/112 coupes and cabs)official website
The Coupe Group on Facebook

"Too many people are working at jobs they hate, to buy things they don't particularly want, to impress people they don't even care about." --Dr. Deepak Chopra
DirectLA is offline  
post #3 of 3 (permalink) Old 04-26-2010, 02:01 PM
BenzWorld Elite
MTI's Avatar
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Warranty claim.
MTI is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    New GLK owner here with question... cyberglk350 X164 GL-Class 1 10-11-2009 12:18 PM
    New GLK Owner DUKE_NS X204 GLK-Class 1 09-12-2009 09:27 PM
    New GLK Owner Needs Advice on Maintaining Black Paint Ronsell General Mercedes-Benz 1 07-17-2009 07:23 PM
    Need some Answers Demfer W163 M-Class 2 12-18-2008 11:51 PM
    New member - Future GLK owner Hy-man General Mercedes-Benz 0 10-07-2008 07:49 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome