Just another novice with problems - Please Help - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-24-2010, 02:12 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Just another novice with problems - Please Help

Hi there,

I'm new on the block and I'd like to pay homage to the legends and as custom demands, pay respect to all.

Whilst I'd like to extend my knowledge about mercedes to all, I'm afraid I'm going to have the learn the lot before I can contribute. So until Chi Kum Ciao and before the cock crows, as we say in my native language, "ayekoooo"

Now for the serious part,

just bought a mercedes slk 1996 model. I've only had the car for five days and whilst driving to my mechanic to give it a thorough check over and a possible service, I saw the battery light come on. My knowledge of cars tells me, there's gotto be something wrong with the alternator, it wasn't long before the car "gazumped" on me. Luckily, I was right in front of a kwik-fit garage so I managed to get the car towed into the pit and they checked the battery over. Lo and behold, because the car had been standing unused for about a year, which was what the previous owner told me, the battery had gone into "non-resurrectable" mode. After careful thought and advice from my mechanic, I bought a new battery and had it fitted. They also run a test on the charge and advised me that, the alternatopr wasn't delivering enough charge so I'd better get it checked quickly, so off I went, to the local auto electrician.

After a visit to the electrician (and £120.00 lighter) for an alternator replacement, I noticed the car is stuck in a low gear and doesn't move through the gears.

I then got my mechanic to give it a drive and he confirmed something wasn't right so a trip back to the auto electrician is my priority tomorrow morning.

I would be grateful if someone, a legend, an expert or a knowledgable SLK owner could point out what the problem might be. I don't want to go there tomorrow like an idiot and be told stories, so perhaps a little insight into what questions I should be asking or indeed how to remedy this situation would be real handy.

What could be the problem???? Please help, as I only bought the car less than a wk ago. Thanks for your help.
Dreadman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-25-2010, 06:03 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Welcome aboard
your car sounds like it's in limp home mode.
it maybe something as simple as a maf sensor ($150) that needs to be replaced
also look into the R170 SLK Class - Benzworld.org - Mercedes-Benz Discussion Forum for help from other slk owners.
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
MB Novice considering used 03 E320 GoNavy General Mercedes-Benz 2 01-25-2009 09:42 AM
Novice Bluetooth Questions smarten W164 M-Class 3 08-22-2007 07:32 PM
Novice with 450SL:s Amigo R/C107 SL/SLC Class 2 10-14-2003 08:02 PM
G-Class ?'s from a novice JYogi G-Class 2 02-28-2003 07:07 AM
Mercedes novice Mike E. W126 S,SE,SEC,SEL,SD,SDL Class 6 02-11-2003 02:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome