engine shut off and loss of power brakes - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-16-2010, 09:49 PM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2009
Vehicle: 1994 S350D
Location: hot humid houston texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
engine shut off and loss of power brakes

I have an excellent condition (125k) S350D diesel 1994 model that has a hard time shutting off and now the brakes are loosing their power. I have brakes but have to push hard. Is this a vacuum pump and is it easy to replace? Any known threads and pics would be great. Want to do this myself....
rhoadrw is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-17-2010, 12:18 AM
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The "power" of power brakes comes from engine vacuum and having that vacuum multiplied by the brake booster. So, you should be checking the vacuum line to the booster and then making sure the booster doesn't have a leak or fault.
MTI is offline  
post #3 of 5 (permalink) Old 04-17-2010, 08:18 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2009
Vehicle: 1994 S350D
Location: hot humid houston texas
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks for the reply. If the engine is not shutting off properly would not that mean its the vacuum pump and not the brake booster? do i need a special vacuum gauge to test its vacuum? What should the psi be? By the way the engine shutoff and brakes work some times but its been getting progressively worse.
rhoadrw is offline  
post #4 of 5 (permalink) Old 04-17-2010, 09:02 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,323
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by rhoadrw View Post
thanks for the reply. If the engine is not shutting off properly would not that mean its the vacuum pump and not the brake booster? do i need a special vacuum gauge to test its vacuum? What should the psi be? By the way the engine shutoff and brakes work some times but its been getting progressively worse.
The car specific forum would know these issues better. But isn't it more likely a leak somewhere, an intermittent leak perhaps?
Diesel Benz is offline  
post #5 of 5 (permalink) Old 04-17-2010, 09:08 AM
BenzWorld Veteran
 
ollo's Avatar
 
Date registered: May 2009
Vehicle: S430 93K; E420 243K; 240D 242K
Location: Near Sublimity, Orygun
Posts: 625
Mentioned: 1 Post(s)
Quoted: 65 Post(s)
Garage
Problem may be a failed or failing check valve on the line to the power brake reservoir or the reservoir itself may be leaking.
ollo is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Engine loss power eatorrijos W203 C-Class 2 07-25-2010 07:37 PM
    Loss of engine power and shushing on accelerating Jon Proffitt W163 M-Class 2 10-12-2008 02:35 AM
    Loss Of Engine Power - Help chrisw140 W140 S-Class 3 05-29-2007 10:22 PM
    Sudden loss of engine power John Peerce W202 C-Class 5 09-12-2005 12:09 PM
    Engine Power Loss gmurnane Vintage Mercedes-Benz 1 06-05-2005 09:25 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome