99 c280 Front Windows/Mirrors Do Not Work - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-15-2010, 09:04 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
99 c280 Front Windows/Mirrors Do Not Work

Hi, my front mirrors and windows do not operate. My rear windows work fine. I replaced the window switch and still have the same problem. I just read in another thread that this could be due to water in the door causing a relay to trip. Generally, if i disconnect the battery, the windows will work again..or at least untill it rains??

Any advice would be greatly appreciated..or how to prevent water gaining access to my door?

-Joe
Joey Benz is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-21-2010, 12:01 PM
BenzWorld Junior Member
 
Date registered: May 2010
Vehicle: 1998 E 320, 131.000 miles
Location: Chicago
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
mercedes 99 c280-all power windows and mirrors not working

Hey I was wondering if you ever found a solution to the problem..I am having the exact same problem on my car, none of the power windows mirrors or trunk release switch work,BUT when I disconnect the battery for 3 seconds they all work just fine for about 15 minutes...I checked the fuses in front in trunk and the relays out in the front they all are fine....

ANY suggestion would be appreciated..its driving me nuts!
Thanks


-----------------------------UPDATE:::

For window problems on a mercedes c220-230-280-1994-2000 year.....p.s. mine was a 99 c280.

For all of you people having problems with windows...not working in the front or back..mirrors and airbag sign doesnt come on at the Window switch assembly by the gear knob...THEN you most like have the problem with the window switch assembly!!!!Before you buy a used one from ebay or local junk yard DO THIS:
around the gear shift there is a square plastic, take it out, take the whole window switch assembly OUT..it should all come out ...there is 2 plugs in the back of it...plug them off...

With the ignition on...put the plugs back on..and try the windows if they work..if they do it is the switch assembly faulty..just get another one

I would assume that you have checked the fuses under the hood...and in the trunk before..
Also another way is to take out the battery for a minute and plug it back on..i used to do that and switches would work fine for 20 minutes or so..than id have to take the battery out again or the plug on the switch assembly.


On the alldata...there was a note from mercedes that there is big problem with water entering through the back doors...so they advised sometimes to check the door modules..to make sure there isnt any corrosion ..and if there is signs of water in it sometimes just pluggin it off might let the other windows work ...

I hope this helps!!good luck!

Last edited by wolfb7; 07-11-2010 at 11:33 PM. Reason: found the solution GOD
wolfb7 is offline  
post #3 of 10 (permalink) Old 11-30-2010, 06:35 PM
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
We had an unfortunate spill this weekend into the console of my '99 E300TD and had the same symptoms of windows, mirrors, and trunk release not working. However, the switches do eliminate with the headlights on, and the antilock break switch at the top also works (separate connector and on the dry end of the spill).

I tried the trick of disconnecting the switch, turning on the ignition switch, and then replugging the connectors with no response - both with the car started and the ignition on only - no difference.

I have a can of electronics spray that I will use to attempt cleaning out the switches and connectors but believe I will come up empty handed and need to buy the used switch on Ebay for $130.

Any other recommendations ...
---
Tom Phillip (concordian) 262.391.4476
concordian is offline  
post #4 of 10 (permalink) Old 12-02-2010, 07:02 PM
BenzWorld Junior Member
 
Date registered: May 2010
Vehicle: 1998 E 320, 131.000 miles
Location: Chicago
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by concordian View Post
We had an unfortunate spill this weekend into the console of my '99 E300TD and had the same symptoms of windows, mirrors, and trunk release not working. However, the switches do eliminate with the headlights on, and the antilock break switch at the top also works (separate connector and on the dry end of the spill).

I tried the trick of disconnecting the switch, turning on the ignition switch, and then replugging the connectors with no response - both with the car started and the ignition on only - no difference.

I have a can of electronics spray that I will use to attempt cleaning out the switches and connectors but believe I will come up empty handed and need to buy the used switch on Ebay for $130.

Any other recommendations ...
---
Tom Phillip (concordian) 262.391.4476


hey man, sorry for the late response. i would certainly try cleaning it and letting it dry for a good 20 minutes. Also I know that there is a relay that controls it, but on mine it wasn't that the problem.
If that doesnt work i'd say to get a used one from the local junkyard or ebay. I paid 80$ for mine and it solved the problem.
wolfb7 is offline  
post #5 of 10 (permalink) Old 12-03-2010, 02:56 PM
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I ended up purchasing the used unit on Ebay after the 3 fuse boxes all checked out. I expect the new switch will do the trick.
---
God's blessings ...
Tom Phillip
concordian is offline  
post #6 of 10 (permalink) Old 02-06-2011, 03:36 PM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: C280, 1999
Location: Oregon
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by concordian View Post
I ended up purchasing the used unit on Ebay after the 3 fuse boxes all checked out. I expect the new switch will do the trick.
---
God's blessings ...
Tom Phillip
Did you have a favorable result with the replacement window switch assemble? Or, was it something else? THX

I've a C280, 1999, the passenger side rear window doesn't operate. I pulled the assemble from the shift console, did the replug and it still refused to work. I'm wondering how to further diagnose the one window failure. Also, I'm doing the ECU reset every day to make the other windows and the mirrors work...
oregon321 is offline  
post #7 of 10 (permalink) Old 02-06-2011, 04:20 PM
BenzWorld Junior Member
 
Date registered: May 2010
Vehicle: 1998 E 320, 131.000 miles
Location: Chicago
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by oregon321 View Post
Did you have a favorable result with the replacement window switch assemble? Or, was it something else? THX

I've a C280, 1999, the passenger side rear window doesn't operate. I pulled the assemble from the shift console, did the replug and it still refused to work. I'm wondering how to further diagnose the one window failure. Also, I'm doing the ECU reset every day to make the other windows and the mirrors work...
Hey im not sure for only one window, but if you have to reset the main switch or ecu in order for it to operate the mirrors and the windows i'd go with the main switch assembly... or you can try plugging out the window that is not working and see if the mirrors and the other windows will work..in that case Id suggest that the actual module of the one not working window is the problem.
Good luck!
wolfb7 is offline  
post #8 of 10 (permalink) Old 02-07-2011, 07:50 AM
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The used module did the trick for me! be careful that the switch layout is the same as yours ... the bezel was wrong but the number of switches and their layout was the same and worked just fine for me.
concordian is offline  
post #9 of 10 (permalink) Old 02-07-2011, 07:04 PM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: C280, 1999
Location: Oregon
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by wolfb7 View Post
Hey im not sure for only one window, but if you have to reset the main switch or ecu in order for it to operate the mirrors and the windows i'd go with the main switch assembly... or you can try plugging out the window that is not working and see if the mirrors and the other windows will work..in that case Id suggest that the actual module of the one not working window is the problem.
Good luck!
Thank you kindly for your response.

I'm searching for a replacement main switch assembly. New is $350+. Do you have any good hunting spots for me?

I wonder how I would unplug the bad window? I thought that I could pull the switch for it from the assemble but it is part of a circuit board. I suppose that I could open the back door panel and unplug it there. Is there an easy way to uplug the one window?
oregon321 is offline  
post #10 of 10 (permalink) Old 02-07-2011, 07:14 PM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: C280, 1999
Location: Oregon
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by concordian View Post
The used module did the trick for me! be careful that the switch layout is the same as yours ... the bezel was wrong but the number of switches and their layout was the same and worked just fine for me.
Congratulations, you are a success! Way to go. Love it. And you are encouraging me.

I'm not finding much on ebay. What key words did you use to search? Something like this, "mercedes main swith assembly."

Thank you for your help.

A few pics of my, 1999 C280, window switch assembly for your amusement:

Top:


Bottom:


Wire connection:

Last edited by oregon321; 02-07-2011 at 07:32 PM. Reason: add pic
oregon321 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1998 C280 front windows/mirrors stopped working froggy67 W202 C-Class 6 09-08-2009 10:50 AM
    no front power windows, seats, mirrors jjohnv W210 E-Class 13 12-02-2008 10:36 PM
    my mirrors, locks, and windows dont work!! newb1e W163 M-Class 9 11-21-2008 06:48 AM
    03 ml 350 windows, locks, mirrors, dont work newb1e Audio & Telematics Forum 0 11-20-2008 01:33 PM
    front windows, mirrors and alarm gchild W202 C-Class 2 04-02-2007 03:00 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome