W203 screaming sound when starting - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-14-2010, 04:23 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
W203 screaming sound when starting

Hi, i drive a W203 C180 automatic (non kompressor), 2002 model, i have had this problem before hand, i took it in and the guy told me its something to do about the climate in south africa that he changed on the computer, its been working for 6 months now and its starting to do the same thing, when i start the car, it make a very loud noise, it sound like a high pitched motor that's running without oil, when i turn the car of it stops, and when i start it again its fine,the noise is gone, this happens each morning (and only in the mornings), and i cant say for sure, but it seems like its on the cold mornings?, what can this be?, the other problem that i had that also started reappearing is when i hit the accelerator the car accelerates very very slowly and then it kick in, what is this? how can i fix this?
neliobaas is offline  
Sponsored Links
post #2 of 4 (permalink) Old 04-14-2010, 08:03 AM
BenzWorld Elite
Date registered: Feb 2008
Vehicle: 2004 W220 (S430) ; 2001 R129 (SL500) Sport
Location: Alabama Gulf Coast--formerly Charlottesville, VA
Posts: 1,335
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Could be serpentine belt. They sometimes squeal like that when they are cold, but stop once they've warmed a bit. Check the belt to see if it is cracked or shiny and needs replacing. You didn't say how many miles on your car, but they need replacement every 60k or so depending on climate and driving conditions. It may also be the tensioner is not working properly and keeping the belt properly taut over the accessory pulleys.

I can't help with the acceleration problem except to venture a guess that there is a fuel feed problem which could be ECU related, MAF related, or fuel system related.


"Don't pick a fight with an old man. If he is too old to fight, he'll just kill you."--John Steinbeck
DrJfrmLA is offline  
post #3 of 4 (permalink) Old 04-14-2010, 08:52 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks man, i really appreciate your help!!!
neliobaas is offline  
post #4 of 4 (permalink) Old 04-14-2010, 09:41 AM
Outstanding Contributor
keyhole's Avatar
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,359
Mentioned: 9 Post(s)
Quoted: 343 Post(s)
Also consider the water pump with bearings failure.. They can make squealing noises that come & go at start-up ....
keyhole is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Grinding sound when starting??? gdpinc W123 E,CE,D,CD,TD,TE Class 3 08-15-2007 04:42 PM
    My New W123: Screaming Eagle Sound dentate gyrus W123 E,CE,D,CD,TD,TE Class 3 04-16-2007 03:21 PM
    Fintail Screaming Sound? Richard 220Sb Vintage Mercedes-Benz 4 06-29-2006 06:43 PM
    Clicking sound when starting up Dene314 R170 SLK-Class 10 04-13-2006 10:43 AM
    Rain + Sandy Mud+8 inch deep puddles+turkeys= Screaming Banshee sound from engine bay? Adoni G-Class 11 03-27-2006 08:58 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome